Compatible Apache Kafka Versions - Amazon Managed Streaming for Apache Kafka

Compatible Apache Kafka Versions

The Apache Kafka versions to which you can update the cluster.

URI

/v1/compatible-kafka-versions

HTTP Methods

GET

Operation ID: GetCompatibleKafkaVersions

Returns a list of the Apache Kafka versions to which you can update this cluster.

Query Parameters
Name Type Required Description
clusterArn String False
Responses
Status Code Response Model Description
200 GetCompatibleKafkaVersionsResponse

200 response

400 Error

The request isn't valid because the input is incorrect. Correct your input and then submit it again.

401 Error

The request is not authorized. The provided credentials couldn't be validated.

403 Error

Access forbidden. Check your credentials and then retry your request.

404 Error

The resource could not be found due to incorrect input. Correct the input, then retry the request.

429 Error

429 response

500 Error

There was an unexpected internal server error. Retrying your request might resolve the issue.

503 Error

503 response

Schemas

Response Bodies

Example GetCompatibleKafkaVersionsResponse

{ "compatibleKafkaVersions": [ { "sourceVersion": "string", "targetVersions": [ "string" ] } ] }

Example Error

{ "message": "string", "invalidParameter": "string" }

Properties

CompatibleKafkaVersion

Contains source Apache Kafka versions and compatible target Apache Kafka versions.

Property Type Required Description
sourceVersion

string

False

An Apache Kafka version.

targetVersions

Array of type string

False

A list of Apache Kafka versions.

Error

Returns information about an error.

Property Type Required Description
message

string

False

The description of the error.

invalidParameter

string

False

The parameter that caused the error.

GetCompatibleKafkaVersionsResponse

Response body for GetCompatibleKafkaVersions.

Property Type Required Description
compatibleKafkaVersions

Array of type CompatibleKafkaVersion

False

A list of CompatibleKafkaVersion objects.

See Also

For more information about using this API in one of the language-specific AWS SDKs and references, see the following:

GetCompatibleKafkaVersions