Impor uma versão mínima do TLS - AWS Command Line Interface

As traduções são geradas por tradução automática. Em caso de conflito entre o conteúdo da tradução e da versão original em inglês, a versão em inglês prevalecerá.

Impor uma versão mínima do TLS

Para aumentar a segurança ao se comunicar com serviços da AWS, você deve usar o TLS 1.2 ou posterior. Quando você usa a AWS CLI, o Python é usado para definir a versão do TLS.

A AWS CLI versão 2 usa um script Python interno que é compilado para usar no mínimo o TLS 1.2 quando compatível com o serviço com o qual ele está conversando. Contanto que você use a AWS CLI versão 2, não serão necessárias outras etapas para aplicar esse mínimo.