Destinos para o AWS DMS - AWSDatabase Migration Service

As traduções são geradas por tradução automática. Em caso de conflito entre o conteúdo da tradução e da versão original em inglês, a versão em inglês prevalecerá.

Destinos para o AWS DMS

É possível usar os seguintes datastores como endpoints de destino de migração de dados usando o AWS DMS.

Bancos de dados locais e de instância Amazon EC2

  • Oracle versões 10g, 11g, 12c, 18c e 19c para as edições Enterprise, Standard, Standard One e Standard Two.

  • Microsoft SQL Server versões 2005, 2008, 2008R2, 2012, 2014, 2016, 2017 e 2019 para as edições Enterprise, Standard, Workgroup e Developer. As edições Web e Express não são compatíveis.

  • MySQL, versões 5.5, 5.6, 5.7 e 8.0

  • MariaDB (compatível como destino de dados compatível com MySQL) versões 10.0.24 a 10.0.28, 10.1, 10.2, 10.3 e 10.4.

    nota

    O suporte ao MariaDB como destino está disponível em todas as versões do AWS DMS com as quais o MySQL é compatível.

  • PostgreSQL versão 9.4 e posterior (para versões 9.x), 10.x, 11.x e 12.x.

    nota
    • É oferecido suporte ao PostgreSQL versões 12.x como um destino no AWS DMS versões 3.3.3 e posterior.

  • Versões do SAP Adaptive Server Enterprise (ASE) 15, 15.5, 15.7, 16 e posteriores

  • Redis versões 6.x.

Bancos de dados de instâncias do Amazon RDS, Amazon Redshift, Amazon DynamoDB, Amazon OpenSearch Service, Amazon ElastiCache for Redis, Amazon Kinesis Data Streams, Amazon DocumentDB, Amazon Neptune e Apache Kafka

  • Oracle versões 11g (versões 11.2.0.3.v1 e posterior), 12c, 18c e 19c para as edições Enterprise, Standard, Standard One e Standard Two.

  • Microsoft SQL Server versões 2008R2, 2012, 2014, 2016, 2017 e 2019 para as edições Enterprise, Standard, Workgroup e Developer. As edições Web e Express não são compatíveis.

  • MySQL, versões 5.5, 5.6, 5.7 e 8.0

  • MariaDB (compatível como destino de dados compatível com MySQL) versões 10.0.24 a 10.0.28, 10.1, 10.2.10.3 e 10.4.

    nota

    O suporte ao MariaDB como destino está disponível em todas as versões do AWS DMS com as quais o MySQL é compatível.

  • PostgreSQL versão 9.4 e posterior (para versões 9.x), 10.x, 11.x e 12.x.

    nota

    É oferecido suporte ao PostgreSQL versões 12.x como um destino no AWS DMS versões 3.3.3 e posterior.

  • Amazon Aurora MySQL-Compatible Edition

  • Amazon Aurora PostgreSQL-Compatible Edition

  • Amazon Aurora sem servidor

  • Amazon Redshift

  • Amazon S3

  • Amazon DynamoDB

  • Amazon OpenSearch Service

  • Amazon ElastiCache for Redis

  • Amazon Kinesis Data Streams

  • Amazon DocumentDB (com compatibilidade com o MongoDB)

  • Amazon Neptune

  • Apache Kafka —Amazon Managed Streaming for Apache Kafka (Amazon MSK)eApache Kafka autogerenciado

Para obter mais informações sobre como trabalhar com um destino específico, consulteTrabalho comAWS DMSEndpoints de.