Configuração para o Amazon Kinesis Data Streams - Amazon Kinesis Data Streams

As traduções são geradas por tradução automática. Em caso de conflito entre o conteúdo da tradução e da versão original em inglês, a versão em inglês prevalecerá.

Configuração para o Amazon Kinesis Data Streams

Antes de usar o Amazon Kinesis Data Streams pela primeira vez, execute as seguintes tarefas.

Cadastre-se na AWS

Quando você se cadastra na Amazon Web Services (AWS), aAWS conta da é cadastrada automaticamente em todos os serviços daAWS, incluindo o Kinesis Data Streams. Você será cobrado apenas pelos serviços que usar.

Se já tiver uma conta da AWS, passe para a próxima tarefa. Se você ainda não possuir uma conta da AWS, use o procedimento a seguir para criar uma.

Para se cadastrar em uma conta da AWS
  1. Abra https://portal.aws.amazon.com/billing/signup.

  2. Siga as instruções on-line.

    Parte do procedimento de inscrição envolve receber uma chamada telefônica e inserir um código de verificação no teclado do telefone.

    Quando você se cadastra em uma Conta da AWS, um usuário raiz da Conta da AWS é criado. O usuário raiz tem acesso a todos os Serviços da AWS e recursos na conta. Como prática recomendada de segurança, atribua acesso administrativo a um usuário administrativo e use somente o usuário raiz para realizar as tarefas que exigem acesso do usuário raiz.

Fazer download de bibliotecas e ferramentas

As seguintes bibliotecas e ferramentas ajudarão você a trabalhar com o Kinesis Data Streams:

Configurar seu ambiente de desenvolvimento

Para usar o KCL, certifique-se de que seu ambiente de desenvolvimento Java atenda aos seguintes requisitos:

  • Java 1.7 (Java SE 7 JDK) ou posterior. Você pode fazer download do software Java mais recente em Java SE Downloads no site da Oracle.

  • Pacote Apache Commons (código, cliente HTTP e logs)

  • Processador Jackson JSON

Observe que o AWS SDK for Java inclui o Apache Commons e o Jackson na pasta de terceiros. No entanto, o SDK for Java funciona com o Java 1.6, enquanto a Kinesis Client Library exige o Java 1.7.