Pré-requisitos - Amazon Kinesis Data Streams

As traduções são geradas por tradução automática. Em caso de conflito entre o conteúdo da tradução e da versão original em inglês, a versão em inglês prevalecerá.

Pré-requisitos

Estes são os requisitos para concluir o Tutorial: Processar dados de ações em tempo real usando KCL e KCL 1.x.

Conta da Amazon Web Services

Antes de começar, familiarize-se com os conceitos abordados em Terminologia e conceitos do Amazon Kinesis Data Streams, especialmente fluxos, estilhaços, produtores e consumidores. Também é útil ter concluído Instalar e configurar o AWS CLI.

Você precisa de uma conta da AWS e de um navegador da web para acessar o AWS Management Console.

Para acessar o console, use seu nome de usuário e senha do IAM para fazer login noAWS Management ConsoledoPágina de login do IAM. O IAM permite que você controle com segurança o acesso aoServiços da AWSE recursos do seuConta da AWS. Para obter detalhes sobre credenciais programáticas e de console, consulteCompreender e obter suas credenciais de segurançanoAWSReferência geral.

Para obter mais informações sobre o IAM e instruções de configuração de chave de segurança, consulteCriar um usuário do IAM.

Requisitos de software do sistema

O sistema usado para executar o aplicativo precisa ter o Java 7 ou superior instalado. Para fazer download e instalar o Java Development Kit (JDK) mais recente, acesse o Site de instalação do Java SE da Oracle.

Se você tiver um Java IDE, como o Eclipse, poderá abrir o código-fonte, editá-lo, compilá-lo e executá-lo.

Você precisa da versão mais recente do AWS SDK for Java. Se você usar o Eclipse como IDE, poderá instalar oAWSToolkit for EclipseEm vez disso.

O aplicativo consumidor requer a Kinesis Client Library (KCL) versão 1.2.1 ou superior, que você pode obter doGitHubemKinesis Client Library (Java).

Próximas etapas

Etapa 1: Criar um streaming de dados