Configurar o toolkit - AWS Toolkit for Eclipse

As traduções são geradas por tradução automática. Em caso de conflito entre o conteúdo da tradução e da versão original em inglês, a versão em inglês prevalecerá.

Configurar o toolkit

Esta seção descreve como instalar ou atualizar o Toolkit for Eclipse.

Pré-requisitos

O Toolkit for Eclipse tem os seguintes pré-requisitos:

  • Uma conta da Amazon Web Services— Como obter umAWSConta, vá para a barra de ferramentasAWSPágina inicial doE clique emCadastrar-se agora. O cadastro permitirá usar todos os serviços oferecidos pelaAWS.

  • Um sistema operacional com suporte— O Toolkit for Eclipse é compatível com Windows, Linux, macOS ou Unix.

  • Java 1.8

  • Eclipse IDE para desenvolvedores Java 4.2 ou posterior— Tentamos manter o Toolkit for Eclipse atualizado com a versão padrão disponível noPágina Download do Eclipse.

    nota

    O Eclipse oferece vários downloads diferentes. Recomendamos que você instale oEclipse IDE para desenvolvedores Java corporativos, que inclui oPlataforma Eclipse Web ToolsRequerido pelo Elastic Beanstalk, oPlataforma de ferramentas de dados Eclipsenecessário para os recursos do Amazon SimpleDB, oEclipse eGit, e oM2Eclipse. Se você instalar outra versão do Eclipse, certifique-se de que tenha (ou de que instalou, usando os links fornecidos) suporte para esses recursos.

Instalar o Toolkit for Eclipse

Para instalar oAWSToolkit for Eclipse

  1. Dentro do Eclipse, clique em Help (Ajuda) e em Install New Software (Instalar novo software).

  2. NoTrabalhar comcaixa, tipohttps://aws.amazon.com/eclipse; e pressioneEnter.

  3. Escolha os componentes do Toolkit for Eclipse que você deseja instalar. Clique em Select All (Selecionar tudo) para instalar todos os componentes de uma só vez.

    nota
    • AWSToolkit for Eclipse Core(noAWSFerramentas básicas de gerenciamentoseção) érequeridos; todos os outros componentes são opcionais.

    • O Support para os gerenciadores do Amazon RDS ou do Amazon SimpleDB exige que oPlataforma de ferramentas de dados Eclipse(DTP) está instalado. A DTP é instalada por padrão com a versão "Java EE Developers" do Eclipse ou pode ser instalada separadamente.

  4. Assim que você tiver feito as seleções, clique em Next (Próximo) (ou em Finish (Concluir)) para concluir a instalação.

Depois de configurar o Toolkit for Eclipse você deveráConfigurar oAWSCredenciais.

nota

Dependendo das opções selecionadas e de fatores como velocidade da rede, latência do servidor e recursos do sistema, pode demorar até 30 minutos para a instalação ser concluída.

Atualize o Toolkit for Eclipse

Para atualizar ou reinstalar o Toolkit for Eclipse, use as mesmas instruções paraInstalação do toolkit.

Algumas versões do Eclipse, (notadamente, Mars e Neon), podem deixar de obter os artefatos mais recentes por causa de um bug em versões anteriores do plug-in Oomph. Para contornar esse problema:

  1. Certifique-se de que você esteja usandohttps://aws.amazon.com/eclipse/site.xmlComo o site de atualização do Toolkit for Eclipse.

  2. Exclua o diretório ~/.eclipse/org.eclipse.oomph.p2/cache/ para remover o conteúdo armazenado em cache.

  3. Instale a versão mais recente do Oomph (Eclipse Installer).