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Solução de problemas AWS Client VPN: o acesso a um Amazon S3 VPC emparelhado ou à Internet é intermitente
Problema
Tenho problemas intermitentes de conectividade ao me conectar a um Amazon VPC S3 emparelhado ou à Internet, mas o acesso às sub-redes associadas não é afetado. Preciso me desconectar e reconectar para resolver os problemas de conectividade.
Causa
Os clientes se conectam a um VPN endpoint do cliente com base no algoritmo DNS round-robin. Isso significa que o tráfego pode ser roteado por qualquer uma das sub-redes associadas quando eles estabelecem uma conexão. Portanto, eles poderão enfrentar problemas de conectividade se estiverem em uma sub-rede associada que não tenha as entradas de rota necessárias.
Solução
Verifique se o VPN endpoint do cliente tem as mesmas entradas de rota com destinos para cada rede associada. Isso garante que os clientes tenham acesso a todas as rotas, independentemente da sub-rede associada pela qual o tráfego é roteado.
Por exemplo, digamos que seu VPN endpoint de cliente tenha três sub-redes associadas (sub-rede A, B e C) e você queira habilitar o acesso à Internet para seus clientes. Para fazer isso, adicione três rotas 0.0.0.0/0
– uma que tenha como destino cada sub-rede associada:
-
Rota 1:
0.0.0.0/0
para a sub-rede A -
Rota 2:
0.0.0.0/0
para a sub-rede B -
Rota 3:
0.0.0.0/0
para a sub-rede C