Menu
AWS SDK for JavaScript
Developer Guide for SDK v2

Web Browsers Supported

The SDK for JavaScript supports all modern web browsers, including these minimum versions:

Browser Version
Google Chrome 28.0+
Mozilla Firefox 26.0+
Opera 17.0+
Microsoft Edge 25.10+
Windows Internet Explorer 10+
Apple Safari 5+
Android Browser 4.3+

Note

Frameworks such as AWS Amplify may not offer the same browser support as the SDK for JavaScript. Check the frameworks documentation for details.