You are viewing documentation for version 2 of the AWS SDK for Ruby. Version 3 documentation can be found here.

Class: Aws::Lambda::Types::ListLayerVersionsRequest

Inherits:
Struct
  • Object
show all
Defined in:
(unknown)

Overview

Note:

When passing ListLayerVersionsRequest as input to an Aws::Client method, you can use a vanilla Hash:

{
  compatible_runtime: "nodejs", # accepts nodejs, nodejs4.3, nodejs6.10, nodejs8.10, nodejs10.x, nodejs12.x, java8, java8.al2, java11, python2.7, python3.6, python3.7, python3.8, dotnetcore1.0, dotnetcore2.0, dotnetcore2.1, dotnetcore3.1, nodejs4.3-edge, go1.x, ruby2.5, ruby2.7, provided, provided.al2
  layer_name: "LayerName", # required
  marker: "String",
  max_items: 1,
}

Instance Attribute Summary collapse

Instance Attribute Details

#compatible_runtimeString

A runtime identifier. For example, go1.x.

Possible values:

  • nodejs
  • nodejs4.3
  • nodejs6.10
  • nodejs8.10
  • nodejs10.x
  • nodejs12.x
  • java8
  • java8.al2
  • java11
  • python2.7
  • python3.6
  • python3.7
  • python3.8
  • dotnetcore1.0
  • dotnetcore2.0
  • dotnetcore2.1
  • dotnetcore3.1
  • nodejs4.3-edge
  • go1.x
  • ruby2.5
  • ruby2.7
  • provided
  • provided.al2

Returns:

  • (String)

    A runtime identifier.

#layer_nameString

The name or Amazon Resource Name (ARN) of the layer.

Returns:

  • (String)

    The name or Amazon Resource Name (ARN) of the layer.

#markerString

A pagination token returned by a previous call.

Returns:

  • (String)

    A pagination token returned by a previous call.

#max_itemsInteger

The maximum number of versions to return.

Returns:

  • (Integer)

    The maximum number of versions to return.