Class: Aws::ApiGatewayV2::Types::MutualTlsAuthentication

Inherits:
Struct
  • Object
show all
Defined in:
gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb

Overview

If specified, API Gateway performs two-way authentication between the client and the server. Clients must present a trusted certificate to access your API.

Constant Summary collapse

SENSITIVE =
[]

Instance Attribute Summary collapse

Instance Attribute Details

#truststore_uriString

An Amazon S3 URL that specifies the truststore for mutual TLS authentication, for example, s3://bucket-name/key-name . The truststore can contain certificates from public or private certificate authorities. To update the truststore, upload a new version to S3, and then update your custom domain name to use the new version. To update the truststore, you must have permissions to access the S3 object.

Returns:

  • (String)


5809
5810
5811
5812
5813
5814
5815
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 5809

class MutualTlsAuthentication < Struct.new(
  :truststore_uri,
  :truststore_version,
  :truststore_warnings)
  SENSITIVE = []
  include Aws::Structure
end

#truststore_versionString

The version of the S3 object that contains your truststore. To specify a version, you must have versioning enabled for the S3 bucket.

Returns:

  • (String)


5809
5810
5811
5812
5813
5814
5815
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 5809

class MutualTlsAuthentication < Struct.new(
  :truststore_uri,
  :truststore_version,
  :truststore_warnings)
  SENSITIVE = []
  include Aws::Structure
end

#truststore_warningsArray<String>

A list of warnings that API Gateway returns while processing your truststore. Invalid certificates produce warnings. Mutual TLS is still enabled, but some clients might not be able to access your API. To resolve warnings, upload a new truststore to S3, and then update you domain name to use the new version.

Returns:

  • (Array<String>)


5809
5810
5811
5812
5813
5814
5815
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 5809

class MutualTlsAuthentication < Struct.new(
  :truststore_uri,
  :truststore_version,
  :truststore_warnings)
  SENSITIVE = []
  include Aws::Structure
end