Class: Aws::CodeArtifact::Types::PackageDependency

Inherits:
Struct
  • Object
show all
Defined in:
gems/aws-sdk-codeartifact/lib/aws-sdk-codeartifact/types.rb

Overview

Details about a package dependency.

Constant Summary collapse

SENSITIVE =
[]

Instance Attribute Summary collapse

Instance Attribute Details

#dependency_typeString

The type of a package dependency. The possible values depend on the package type. Example types are compile, runtime, and test for Maven packages, and dev, prod, and optional for npm packages.

Returns:

  • (String)


2498
2499
2500
2501
2502
2503
2504
2505
# File 'gems/aws-sdk-codeartifact/lib/aws-sdk-codeartifact/types.rb', line 2498

class PackageDependency < Struct.new(
  :namespace,
  :package,
  :dependency_type,
  :version_requirement)
  SENSITIVE = []
  include Aws::Structure
end

#namespaceString

The namespace of the package. The package component that specifies its namespace depends on its type. For example:

  • The namespace of a Maven package is its groupId.

  • The namespace of an npm package is its scope.

  • A Python package does not contain a corresponding component, so Python packages do not have a namespace.

Returns:

  • (String)


2498
2499
2500
2501
2502
2503
2504
2505
# File 'gems/aws-sdk-codeartifact/lib/aws-sdk-codeartifact/types.rb', line 2498

class PackageDependency < Struct.new(
  :namespace,
  :package,
  :dependency_type,
  :version_requirement)
  SENSITIVE = []
  include Aws::Structure
end

#packageString

The name of the package that this package depends on.

Returns:

  • (String)


2498
2499
2500
2501
2502
2503
2504
2505
# File 'gems/aws-sdk-codeartifact/lib/aws-sdk-codeartifact/types.rb', line 2498

class PackageDependency < Struct.new(
  :namespace,
  :package,
  :dependency_type,
  :version_requirement)
  SENSITIVE = []
  include Aws::Structure
end

#version_requirementString

The required version, or version range, of the package that this package depends on. The version format is specific to the package type. For example, the following are possible valid required versions: 1.2.3, ^2.3.4, or 4.x.

Returns:

  • (String)


2498
2499
2500
2501
2502
2503
2504
2505
# File 'gems/aws-sdk-codeartifact/lib/aws-sdk-codeartifact/types.rb', line 2498

class PackageDependency < Struct.new(
  :namespace,
  :package,
  :dependency_type,
  :version_requirement)
  SENSITIVE = []
  include Aws::Structure
end