You are viewing documentation for version 3 of the AWS SDK for Ruby. Version 2 documentation can be found here.

Class: Aws::ElasticsearchService::Types::CompatibleVersionsMap

Inherits:
Struct
  • Object
show all
Defined in:
gems/aws-sdk-elasticsearchservice/lib/aws-sdk-elasticsearchservice/types.rb

Overview

A map from an ElasticsearchVersion to a list of compatible ElasticsearchVersion s to which the domain can be upgraded.

Instance Attribute Summary collapse

Instance Attribute Details

#source_versionString

The current version of Elasticsearch on which a domain is.

Returns:

  • (String)


237
238
239
240
241
# File 'gems/aws-sdk-elasticsearchservice/lib/aws-sdk-elasticsearchservice/types.rb', line 237

class CompatibleVersionsMap < Struct.new(
  :source_version,
  :target_versions)
  include Aws::Structure
end

#target_versionsArray<String>

List of supported elastic search versions.

Returns:

  • (Array<String>)


237
238
239
240
241
# File 'gems/aws-sdk-elasticsearchservice/lib/aws-sdk-elasticsearchservice/types.rb', line 237

class CompatibleVersionsMap < Struct.new(
  :source_version,
  :target_versions)
  include Aws::Structure
end