Class: Aws::RDS::Types::MinimumEngineVersionPerAllowedValue

Inherits:
Struct
  • Object
show all
Defined in:
gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb

Overview

The minimum DB engine version required for each corresponding allowed value for an option setting.

Constant Summary collapse

SENSITIVE =
[]

Instance Attribute Summary collapse

Instance Attribute Details

#allowed_valueString

The allowed value for an option setting.

Returns:

  • (String)


12517
12518
12519
12520
12521
12522
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 12517

class MinimumEngineVersionPerAllowedValue < Struct.new(
  :allowed_value,
  :minimum_engine_version)
  SENSITIVE = []
  include Aws::Structure
end

#minimum_engine_versionString

The minimum DB engine version required for the allowed value.

Returns:

  • (String)


12517
12518
12519
12520
12521
12522
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 12517

class MinimumEngineVersionPerAllowedValue < Struct.new(
  :allowed_value,
  :minimum_engine_version)
  SENSITIVE = []
  include Aws::Structure
end