You are viewing documentation for version 3 of the AWS SDK for Ruby. Version 2 documentation can be found here.

Class: Aws::SSM::Errors::HierarchyLevelLimitExceededException

Inherits:
ServiceError
  • Object
show all
Defined in:
gems/aws-sdk-ssm/lib/aws-sdk-ssm/errors.rb

Instance Method Summary collapse

Constructor Details

#initialize(context, message, data = Aws::EmptyStructure.new) ⇒ HierarchyLevelLimitExceededException

Returns a new instance of HierarchyLevelLimitExceededException

Parameters:



322
323
324
# File 'gems/aws-sdk-ssm/lib/aws-sdk-ssm/errors.rb', line 322

def initialize(context, message, data = Aws::EmptyStructure.new)
  super(context, message, data)
end

Instance Method Details

#messageString

Returns:

  • (String)


327
328
329
# File 'gems/aws-sdk-ssm/lib/aws-sdk-ssm/errors.rb', line 327

def message
  @message || @data[:message]
end