Considerations - IoT Device Simulator

Considerations

Solution Updates

IoT Device Simulator version 2.1.1 uses the most up-to-date Node.js runtime. Version 2.0 uses the Node.js 8.10 runtime, which reaches end-of-life on December 31, 2019. In January, AWS Lambda will block the create operation and, in February, Lambda will block the update operation. For more information, see Runtime Support Policy in the AWS Lambda Developer Guide.

To continue using this solution with the latest features and improvements, you can update the stack.

Regional Deployment

This solution uses the AWS Fargate service, which is currently available in specific AWS Regions only. Therefore, you must launch this solution in a region where AWS Fargate is available. For the most current service availability by region, see AWS service offerings by region.