AWS Systems Manager
API Reference (API Version 2014-11-06)

PatchSource

Information about the patches to use to update the instances, including target operating systems and source repository. Applies to Linux instances only.

Contents

Configuration

The value of the yum repo configuration. For example:

cachedir=/var/cache/yum/$basesearch

$releasever

keepcache=0

debuglevel=2

Type: String

Length Constraints: Minimum length of 1. Maximum length of 512.

Required: Yes

Name

The name specified to identify the patch source.

Type: String

Pattern: ^[a-zA-Z0-9_\-.]{3,50}$

Required: Yes

Products

The specific operating system versions a patch repository applies to, such as "Ubuntu16.04", "AmazonLinux2016.09", "RedhatEnterpriseLinux7.2" or "Suse12.7". For lists of supported product values, see PatchFilter.

Type: Array of strings

Array Members: Minimum number of 1 item. Maximum number of 20 items.

Length Constraints: Minimum length of 1. Maximum length of 128.

Required: Yes

See Also

For more information about using this API in one of the language-specific AWS SDKs, see the following:

On this page: