System requirements - Amazon WorkDocs

System requirements

The Amazon WorkDocs Android phone and tablet client applications require Android 5.1 and later. In addition, the Amazon WorkDocs Android tablet application requires one of the following:

  • Kindle Fire HD 6

  • Kindle Fire HD 7 (2nd Gen and later)

  • Kindle Fire HDX 7 (3rd Gen and later)

  • Kindle Fire HD 8

  • Kindle Fire HDX 8

  • Kindle Fire HD 8.9 (2nd Gen and later)

  • Kindle Fire HDX 8.9 (3rd Gen and later)

  • Kindle Fire HD 10