System requirements - Amazon WorkDocs

System requirements

The Amazon WorkDocs iPhone client application requires the following:

  • An iPhone with iOS 11 or later

The Amazon WorkDocs iPad application requires the following:

  • iPad or later with iOS 11 or later