System requirements - Amazon WorkDocs

System requirements

The Amazon WorkDocs web client requires one of the following browsers:

  • Google Chrome version 30 or later

  • Mozilla Firefox ESR version 24.6 or later

  • Mozilla Firefox version 30 or later

  • Apple Safari version 7 or later

  • Microsoft Internet Explorer 10 or later