開始之前 - Amazon Elastic Compute Cloud

開始之前

請檢閱以下需求和限制,然後完成必要任務,才能使用執行命令建立具備 VSS 功能的 EBS 快照。

重要

AWSVssComponents 套件和 AWSEC2-CreateVssSnapshot 以及 AWSEC2-ManageVssIO SSM 文件不再接收 Windows Server 2008 R2 的更新。

AWSVssComponents 套件支援 Windows Server 2008 R2 最新版本 1.3.1.0 (不含更新版本)。

透過使用 AWSEC2-CreateVssSnapshotGetDocumentAWSEC2-ManageVssIO API 並為 指定 ,您可以查詢 2008R2-VersionName SSM 文件支援的 Windows 2008 R2 的最新版本。例如:

Get-SSMDocument -Name AWSEC2-CreateVssSnapshot -VersionName "2008R2"

Amazon EC2 Windows 執行個體需求

執行 Windows Server 2012 或更新版本的執行個體皆支援具備 VSS 功能的 EBS 快照。請確認執行個體滿足 Amazon EC2 Windows 的所有需求。如需詳細資訊,請參閱 AWS Systems Manager 使用者指南中的設定 AWS Systems Manager

.NET Framework 版本

AWSVssComponents 套件需要 .NET Framework 版本 4.6 及更新版本。如果您使用的是 Windows 2012 或 2012 R2,則預設 .NET Framework 版本為 4.6 之前的版本,您必須使用 Windows Update 安裝 4.6 版或更新版本。

SSM Agent 版本

更新執行個體,以使用 SSM Agent 2.2.58.0 版或更新版本。如果您正在使用舊版 SSM Agent,則可利用執行命令進行更新。如需詳細資訊,請參閱《AWS Systems Manager 使用者指南》中的 使用執行命令更新 SSM Agent

AWS Tools for Windows PowerShell version

請確保執行個體正在執行 3.3.48.0 版或更新版本的 AWS Tools for Windows PowerShell。若要查看版本編號,請在執行個體上執行以下命令:

Get-AWSPowerShellVersion

如果您需要更新執行個體上的 Tools for Windows PowerShell 版本,請參閱 AWS Tools for Windows PowerShell 使用者指南中的在 Windows 電腦上設定 AWS Tools for Windows PowerShell