Aurora MySQL 資料庫引擎更新 2023-03-24 (2.11.2 版,與 MySQL 5.7.12 相容) - Amazon Aurora

本文為英文版的機器翻譯版本,如內容有任何歧義或不一致之處,概以英文版為準。

Aurora MySQL 資料庫引擎更新 2023-03-24 (2.11.2 版,與 MySQL 5.7.12 相容)

版本:2.11.2

Aurora MySQL 2.11.2 已正式推出。Aurora MySQL 2.11 版與 MySQL 5.7.12 相容。如需社群變更的詳細資訊,請參閱 MySQL 5.7.12 中的變更 (2016-04-11,正式推出)

目前支援的 Aurora MySQL 版本包括 2.07.*、2.11.*、3.01.*、3.02.* 和 3.03.*。

您可以將現有的 Aurora MySQL 2.* 資料庫叢集升級至 Aurora MySQL 2.11.2。您也可以將快照從目前支援的任何 Aurora MySQL 版本還原至 Aurora MySQL 2.11.2。

如果您將 Aurora MySQL 全域資料庫升級至 2.11.* 版,則須將主要和次要資料庫叢集升級至完全相同的版本 (包含修補程式等級)。如需升級 Aurora 全球資料庫次要版本的詳細資訊,請參閱次要版本升級

在執行 Aurora MySQL 2.11.* 的就地引擎版本升級後,作業系統升級會自動套用至 db.r4、db.r5、db.t2 和 db.t3 資料庫執行個體類別上所有受影響的執行個體 (如果執行個體執行舊版作業系統的話)。在多可用區域資料庫叢集中,所有讀取器執行個體都會先套用作業系統升級。當第一個讀取器執行個體上的作業系統升級完成時,容錯移轉就會發生,且先前的寫入器執行個體會升級。

注意

在主要版本升級期間,作業系統升級不會自動套用至 Aurora 全球資料庫。

如果您有任何問題或疑慮,可以在社群論壇和 Support AWS 援中心取得 Sup AWS port。如需詳細資訊,請參閱《Amazon Aurora 使用者指南》中的維護 Amazon Aurora 資料庫叢集

注意

如需如何升級 Aurora MySQL 資料庫叢集的詳細資訊,請參閱《Amazon Aurora 使用者指南》中的升級 Aurora MySQL 資料庫叢集的次要版本或修補程式層級

改善項目

一般改進:

  • 已修正連接多個二進位日誌複寫取用者時,使用二進位日誌複寫的資料庫執行個體可能會發生 CPU 使用率和連線失敗次數增加的問題。

  • 已修正如果主要資料庫寫入器使用 Aurora MySQL 2.10 版,則升級至 Aurora MySQL 2.11 版之後,可能會導致全球資料庫次要區域中的讀取器執行個體不同步的問題。

可用性改進項目:

  • 在此 Aurora MySQL 版本中未啟用快速插入,因為在執行、和等查詢時可能會導致不一致的INSERT INTO問題。SELECT FROM如需快速插入最佳化的詳細資訊,請參閱 Amazon Aurora MySQL 效能增強功能

Aurora MySQL 第 2 版中不支援的功能

Aurora MySQL 第 2 版 (與 MySQL 5.7 相容) 目前不支援下列功能。

MySQL 5.7 相容性

此 Aurora MySQL 版本有 MySQL 5.7 線路相容性,包括 JSON 支援、空間索引和產生欄位等功能。相較於 MySQL 5.7,Aurora MySQL 採用的空間索引原生實作主要利用 Z 階曲線,可為空間資料集提供超過 20 倍的寫入效能和超過 10 倍的讀取效能。

此 Aurora MySQL 版本目前不支援下列 MySQL 5.7 功能:

  • 群組複寫外掛程式

  • 已增加的頁面大小

  • 啟動時載入 InnoDB 緩衝集區

  • InnoDB 全文剖析器外掛程式

  • 多來源複寫

  • 線上緩衝集區大小調整

  • 密碼驗證外掛程式

  • 查詢重寫外掛程式

  • 複寫篩選

  • CREATE TABLESPACE SQL 陳述式