Aurora MySQL 資料庫引擎更新 2022-04-20 (3.02.0 版,與 MySQL 8.0.23 相容)。標準支援將於 2024 年 1 月 15 日結束。不支援升級至此版本。 - Amazon Aurora

本文為英文版的機器翻譯版本,如內容有任何歧義或不一致之處,概以英文版為準。

Aurora MySQL 資料庫引擎更新 2022-04-20 (3.02.0 版,與 MySQL 8.0.23 相容)。標準支援將於 2024 年 1 月 15 日結束。不支援升級至此版本。

版本:3.02.0

Aurora MySQL 3.02.0 已正式推出。Aurora MySQL 3.02 版與 MySQL 8.0.23 相容、Aurora MySQL 2.x 版與 MySQL 5.7 相容,Aurora MySQL 1.x 版則與 MySQL 5.6 相容。

如需 Aurora MySQL 第 3 版中新功能的詳細資訊,以及了解 Aurora MySQL 第 3 版與 Aurora MySQL 第 2 版或社群 MySQL 8.0 之間的差異,請參閱《Amazon Aurora 使用者指南》中的比較 Aurora MySQL 第 2 版與 Aurora MySQL 第 3 版

目前支援的 Aurora MySQL 版本包括 1.19.5、1.19.6、1.22.*、1.23.*、2.04.*、2.07.*、2.08.*、2.09.*、2.10.*、3.01.* 和 3.02.*。

您可以將快照從目前支援的任何 Aurora MySQL 第 2 版叢集還原至 Aurora MySQL 3.02.0。

如需規劃升級至 Aurora MySQL 第 3 版的詳細資訊,請參閱《Amazon Aurora 使用者指南》中的 Aurora MySQL 第 3 版的升級規劃。如需升級程序本身的資訊,請參閱《Amazon Aurora 使用者指南》中的升級至 Aurora MySQL 第 3 版。如需有關 Aurora MySQL 升級的一般資訊,請參閱《Amazon Aurora 使用者指南》中的升級 Amazon Aurora MySQL 資料庫叢集

如需故障診斷資訊,請參閱 Aurora MySQL 第 3 版升級問題的故障診斷

如果您有任何問題或疑慮,可以在社群論壇和 Support AWS 援中心取得 Sup AWS port。如需詳細資訊,請參閱《Amazon Aurora 使用者指南》中的維護 Amazon Aurora 資料庫叢集

改善項目

Aurora MySQL 3.02.0 版已正式推出,並與社群 MySQL 8.0.23 全面相容。

以下列出已修正的安全性問題與 CVE:

修正和其他增強功能,以微調在受管環境中的處理。以下 CVE 修正如下所示:

新功能:

可用性改進項目:

  • 已修正當刪除的記錄或捨棄的資料表包含兩個或多個可變長度欄 (VARCHAR、VARBINARY、BLOB 和 TEXT 類型) 時,可能導致伺服器進入重新啟動迴圈並造成無法使用的問題。如需欄類型的詳細資訊,請參閱innodb-row-format

  • 已修正由於叢集上的二進位日誌已開啟且至少有一個二進位日誌取用者連線,導致應用程式與取用者發生爭用,因而造成現有連線逾時且無法建立新連線的問題。

  • 可用的記憶體由FreeableMemory CloudWatch 度量表示。如需詳細資訊,請參閱 Amazon 極光的亞馬遜 CloudWatch 指標

    • 已修正啟用二進位日誌複寫時,可能因可釋放記憶體減少而導致資料庫執行個體重新啟動或容錯移轉的問題。

    • 已修正設定工作階段變數時,可能因可釋放記憶體減少而導致資料庫執行個體重新啟動或容錯移轉的問題。

    • 已修正資料庫處理程序開啟現有檔案時,可能因可釋放記憶體減少而導致資料庫執行個體重新啟動或容錯移轉的問題。

  • 已修正下列問題:在極少數情況下,當插入新列的資料表包含從快照還原的叢集上的 AUTO_INCREMENT 欄時,可能造成重複輸入錯誤。

  • 在此 Aurora MySQL 版本中未啟用快速插入,因為在執行、和等查詢時可能會導致不一致的INSERT INTO問題。SELECT FROM如需快速插入最佳化的詳細資訊,請參閱 Amazon Aurora MySQL 效能增強功能

一般改進:

升級/遷移:

  • 已修正由於將 ibdata 檔案和資料表空間複製到 Aurora 儲存體發生問題,而導致 MySQL 8.0.x 資料庫遷移至 Aurora MySQL 第 3 版失敗的問題。

  • 已修正當資料庫資料表包含大量資料時,可能造成叢集從 Aurora MySQL 第 2 版升級至 Aurora MySQL 第 3 版失敗的問題。

  • 已修正由於為資料表建立序列化資料字典資訊 (SDI) 失敗,而造成從 Aurora MySQL 第 2 版將叢集還原至 Aurora MySQL 第 3 版失敗的問題。

  • 已修正由於 RDS 系統資料表的升級預先檢查回報了結構描述不一致錯誤,而導致從 Aurora MySQL 第 2 版升級至 Aurora MySQL 第 3 版失敗的問題。

  • 已修正由於 RDS 受管預存程序中有無效的語法,而導致從 RDS for MySQL 8.0 或 Aurora MySQL 第 2 版遷移或還原至 Aurora MySQL 第 3 版資料庫失敗的問題。

  • 已修正由於一般日誌慢速日誌資料表的升級預先檢查回報了結構描述不一致錯誤,而導致從 Aurora MySQL 第 2 版升級至 Aurora MySQL 第 3 版失敗的問題。

MySQL 社群版錯誤修正整合

此版本除了下列內容之外,還包括 8.0.23 (含) 以前版本的所有 Community 錯誤修正。如需詳細資訊,請參閱 Aurora MySQL 3.x 資料庫引擎更新修正的 MySQL 錯誤

  • 已修正不當處理用於預存程序內資料指標的暫存資料表,而可能導致非預期的伺服器行為 mysqld-8-0-24-bug 的情形。(錯誤 #32416811)