支援的作業系統 - AWS Systems Manager

支援的作業系統

您的 Amazon Elastic Compute Cloud (Amazon EC2) 執行個體、內部部署伺服器和虛擬機器 (VM) 必須執行以下其中一個作業系統,以便搭配 AWS Systems Manager 使用。

注意

如果您計劃使用 Systems Manager 管理和設定 AWS IoT Greengrass 核心裝置,則這些裝置必須符合 AWS IoT Greengrass 的需求。如需詳細資訊,請參閱《AWS IoT Greengrass Version 2 開發人員指南》中的設定 AWS IoT Greengrass 核心裝置

如果您計劃管理和設定 AWS IoT 和非 AWS 邊緣裝置,則這些裝置必須符合此處列出的需求,並設定為 Systems Manager 的內部部署受管節點。如需詳細資訊,請參閱 設定適用於邊緣裝置的 AWS Systems Manager

Linux

Amazon Linux
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
2012.03 – 2018.03
注意

從 2015.03 版本開始,Amazon Linux 發行 Intel 64-bit (x86_64)。

Amazon Linux 2
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
2.0 和所有更新版本
CentOS
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
6.x¹
7.1 和更新的 7.x 版本
8.0-8.5 版本

¹ SSM Agent 不再正式支援這些版本,也不再更新這些 CentOS 版本的代理程式。CentOS 6 支援 SSM Agent 3.0.1390.0 版及更早的版本。

CentOS Stream
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
8
Debian Server
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
Jessie (8)
Stretch (9)
Buster (10)
Bullseye (11)
Oracle Linux
版本 Intel 32 位元 (x86) Intel 64 位元 (x86_64) ARM 64 位元 (arm64)
7.5-7.8
8.1-8.3
Red Hat Enterprise Linux (RHEL)
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
6.x¹
7.0-7.5
7.6-8.5

¹ SSM Agent 不再正式支援這些版本,也不再更新這些 RHEL 版本的代理程式。RHEL 6 支援 SSM Agent 3.0.1390.0 版及更早的版本。

Rocky Linux
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
8.4-8.5
SUSE Linux Enterprise Server (SLES)
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
12 和更新的 12.x 版本
15 和之後的 15.x 版本
Ubuntu Server
版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
12.04 LTS 和 14.04 LTS
16.04 LTS 和 18.04 LTS
20.04 LTS 和 20.10 STR

macOS

版本 Intel 32 位元 (x86) Intel 64 位元 (x86_64) ARM 64 位元 (arm64)
10.14.x (Mojave)
10.15.x (Catalina)
11.x (BigSur)
注意

macOS 支援僅限於以下 AWS 區域:

  • 美國東部 (維吉尼亞北部) (us-east-1)

  • 美國東部 (俄亥俄) (us-east-2)

  • 美國西部 (奧勒岡) (us-west-2)

  • 歐洲 (愛爾蘭) (eu-west-1)

  • 亞太區域 (新加坡) (ap-southeast-1)

如需有關支援 macOS 的 Amazon EC2 的詳細資訊,請參閱《Amazon EC2 Linux 執行個體使用者指南》中的 Amazon EC2 Mac 執行個體

Raspberry Pi OS (先前為 Raspbian)

版本 ARM 32-bit (arm)
8 (Jessie)
9 (Stretch)

相關內容

使用 AWS Systems Manager 管理 Raspberry Pi 裝置

Windows Server

SSM Agent 需要 Windows PowerShell 3.0 或更新版本,才能在 Windows Server 執行個體上執行特定 AWS Systems Manager 文件 (SSM 文件) (例如,舊版 AWS-ApplyPatchBaseline 文件)。驗證您的 Windows Server 執行個體正在執行 Windows Management Framework 3.0 或更新版本。這個架構包含 Windows PowerShell。如需詳細資訊,請參閱 Windows Management Framework 3.0

版本 Intel 32-bit (x86) Intel 64-bit (x86_64) ARM 64-bit (arm64)
2008¹
2008 R2¹
2012 和 2012 R2
2016
2019
2022

¹ 截至 2020 年 1 月 14 日,Microsoft 不再支援 Windows Server 2008 的功能或安全性更新。Windows Server 2008 和 2008 R2 的舊版 Amazon Machine Images (AMIs) 仍包含預先安裝的 SSM Agent 的版本 2,但 Systems Manager 不再正式支援 2008 版本,並且不再更新這些 Windows Server 版本的代理程式。除此之外,SSM Agent 3.0 版 可能無法與 Windows Server 2008 和 2008 R2 上的所有操作相容。Windows Server 2008 版本的 SSM Agent 的最終的正式支援版本是 2.3.1644.0。