Elastic Beanstalk platform versions scheduled for retirement - AWS Elastic Beanstalk

Elastic Beanstalk platform versions scheduled for retirement

AWS Elastic Beanstalk provides managed platforms that support running web applications developed for specific programming languages, frameworks, and web containers. Elastic Beanstalk offers one or more platform versions for each platform. For details about currently supported platform versions, see Elastic Beanstalk supported platforms.

This page lists platform versions that Elastic Beanstalk has scheduled for retirement, because some of their components are reaching their End of Life (EOL). These platform versions remain available until the published retirement date of their retiring components. For a list of component retirement dates, see AWS Elastic Beanstalk platform support policy in the AWS Elastic Beanstalk Developer Guide.

Note

On July 18, 2022 Elastic Beanstalk set the status of all platform branches based on Amazon Linux AMI (AL1) to retired. For more information, see AL1 platform retirement FAQ in the AWS Elastic Beanstalk Developer Guide.

The following sections provide information about all retiring platform versions.

Node.js

Elastic Beanstalk has scheduled the following Node.js platform versions for retirement.

Platform Version and Solution Stack Name

AMI

Node.js versions (npm versions)

Proxy Server

Git

AWS X-Ray

End Date

Node.js 12 AL2 version 5.5.5

64bit Amazon Linux 2 v5.5.5 running Node.js 12

2.0.20220719

12.22.12 (6.14.16), 12.22.11 (6.14.16), 12.22.10 (6.14.16), 12.22.9 (6.14.15), 12.22.8 (6.14.15), 12.22.7 (6.14.15), 12.22.6 (6.14.15), 12.22.5 (6.14.14), 12.22.4 (6.14.14), 12.22.3 (6.14.13), 12.22.2 (6.14.13), 12.22.1 (6.14.12), 12.22.0 (6.14.11), 12.21.0 (6.14.11), 12.20.2 (6.14.11), 12.20.1 (6.14.10), 12.20.0 (6.14.8), 12.19.1 (6.14.8), 12.19.0 (6.14.8), 12.18.4 (6.14.6), 12.18.3 (6.14.6), 12.18.2 (6.14.5), 12.18.1 (6.14.5), 12.18.0 (6.14.4), 12.17.0 (6.14.4), 12.16.3 (6.14.4), 12.16.2 (6.14.4), 12.16.1 (6.13.4), 12.16.0 (6.13.4), 12.15.0 (6.13.4), 12.14.1 (6.13.4), 12.14.0 (6.13.4), 12.13.1 (6.12.1), 12.13.0 (6.12.0), 12.12.0 (6.11.3), 12.11.1 (6.11.3), 12.11.0 (6.11.3), 12.10.0 (6.10.3), 12.9.1 (6.10.2), 12.9.0 (6.10.2), 12.8.1 (6.10.2), 12.8.0 (6.10.2), 12.7.0 (6.10.0), 12.6.0 (6.9.0), 12.5.0 (6.9.0), 12.4.0 (6.9.0), 12.3.1 (6.9.0), 12.3.0 (6.9.0), 12.2.0 (6.9.0), 12.1.0 (6.9.0), 12.0.0 (6.9.0)

Default version: 12.22.12

nginx 1.20.0 (default), Apache 2.4.54

2.37.1

3.2.0

2022-10-31

For information about current platform versions, see Node.js.

PHP

Elastic Beanstalk has scheduled the following PHP platform versions for retirement.

Platform Version and Solution Stack Name

AMI

Language

Composer

Proxy Server

End Date

PHP 7.4 AL2 version 3.4.0

64bit Amazon Linux 2 v3.4.0 running PHP 7.4

2.0.20220719

PHP 7.4.30

1.10.22

nginx 1.20.0 (default), Apache 2.4.54

2023-05-31

For information about current platform versions, see PHP.

Ruby

Elastic Beanstalk has scheduled the following Ruby platform versions for retirement.

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X-Ray

Proxy Server

End Date

Ruby 2.6 AL2 version 3.4.9

64bit Amazon Linux 2 v3.4.9 running Ruby 2.6

2.0.20220719

Ruby 2.6.10-p210

RubyGems 3.3.18

Puma 5.6.4

3.2.0

nginx 1.20.0

2022-09-30

For information about current platform versions, see Ruby.