Release: Elastic Beanstalk Amazon Linux 2 platform updates on October 06, 2023 - AWS Elastic Beanstalk

Release: Elastic Beanstalk Amazon Linux 2 platform updates on October 06, 2023

This release provides new versions for AWS Elastic Beanstalk platforms based on Amazon Linux 2. The release includes security updates. It also includes AMI, Docker, ECS based Docker, Go, Corretto, Tomcat, .NET Core, Node.js, PHP, Python, and Ruby updates.

Release date: October 06, 2023

Changes

The following table lists the changes included in this release.

Notes
  • These release notes focus on changes to currently supported platform branches. For full version information of Elastic Beanstalk retiring (deprecated) platform branches, see Elastic Beanstalk platform versions scheduled for retirement in the AWS Elastic Beanstalk Platforms guide.

  • Be aware that at the time these release notes are published, the new platform versions might not yet be available in all the AWS Regions that Elastic Beanstalk supports. It might take a few hours for the release to complete.

Category Description

Security updates

Applied all security updates published in the Amazon Linux Security Center on or before October 4, 2023 to all Amazon Linux 2 platforms.

Some of the platform updates are security releases. For more information, see Platform-specific updates in this table.

Cross-platform updates

Made these cross-platform updates:

Component Update

AMI

Updated the base AMI to version 2.0.20230926.

Platform-specific updates

Made these platform-specific updates:

Platform Update

Docker

Updated Amazon ECS Agent to version 1.75.3 on the ECS Amazon Linux 2 platform branch.

Updated Docker Compose to version 2.22.0.

Additional changes with the release:

  • This release adds --ignore-buildable to the docker compose pull command to prevent an issue with pulling images that need a building process with Docker Compose v2. For more information see docker compose pull in the Docker reference documentation.

  • This release prevents deployments from being reported as successful if the container does not start up successfully or unexpectedly stops.

  • This release addresses an issue where the Elastic Beanstalk log file could be appended with duplicate information that's already been logged, on logging restart after the logging process previously failed.

  • This release limits the amount of times docker compose logging will attempt to restart on failure.

Go

Updated Go to release 1.21.2. For details, see go1.21.2 in The Go Programming Language Release History.

Corretto

Updated Corretto 17 to version 17.0.8.8.1. For change log, see Change Log for Amazon Corretto 17.

Updated Corretto 11 to version 11.0.20.9.1. For change log, see Change Log for Amazon Corretto 11.

Tools Updates:

  • Updated Ant to version 1.10.14.

  • Updated Gradle to version 8.4.

Tomcat

Updated Corretto 17 to version 17.0.8.8.1. For change log, see Change Log for Amazon Corretto 17.

Updated Corretto 11 to version 11.0.20.9.1. For change log, see Change Log for Amazon Corretto 11.

Updated Tomcat 8.5 to Tomcat 8.5.93.

.NET Core

Updated .NET Core to release 6.0.22 .

This is a security release.

Note

This releases removes the .NET Core 3.1 runtime from the platform .NET Core on Amazon Linux 2.

Node.js

Updated Node.js 18 to add support for Node version 18.18.0.

This is a security release.

Note

Node.js 14 and Node.js 16 are retiring (deprecated) platform branches. For full version information of Elastic Beanstalk retiring platform branches, see Elastic Beanstalk platform versions scheduled for retirement in the AWS Elastic Beanstalk Platforms guide.

PHP

Updated PHP 8.1 release to 8.1.24.

Updated PHP 8.0 release to 8.0.30.

The PHP 8.0 update is a security release.

Python

Updated Pipenv to release 2023.10.3. For details, see Pipenv release notes.

Note

Python 3.7 is a retiring (deprecated) platform branch. For full version information of Elastic Beanstalk retiring platform branches, see Elastic Beanstalk platform versions scheduled for retirement in the AWS Elastic Beanstalk Platforms guide.

Ruby

Updated RubyGems to release 3.4.20. For details, see 3.4.20 Released on the RubyGems blog.

Updated Puma to version 6.4.0.

Note

Ruby 2.7 and Ruby 3.0 are retiring (deprecated) platform branches. For full version information of Elastic Beanstalk retiring platform branches, see Elastic Beanstalk platform versions scheduled for retirement in the AWS Elastic Beanstalk Platforms guide.

New platform versions

Note

The following tables list all supported platform branches for each platform. Only Amazon Linux 2 platform branches are updated.

Docker

Platform Version and Solution Stack Name

AMI

ECS Agent

Docker

Docker Compose

Proxy Server

Docker AL2023 version 4.0.1

64bit Amazon Linux 2023 v4.0.1 running Docker

2023.1.20230825

20.10.25-1

2.20.3

nginx 1.24.0

Docker AL2 version 3.6.2

64bit Amazon Linux 2 v3.6.2 running Docker

2.0.20230926

20.10.23-1

2.22.0

nginx 1.22.1

ECS AL2 version 3.2.12

64bit Amazon Linux 2 v3.2.12 running ECS

2.0.20230926

1.75.3

Go

Platform Version and Solution Stack Name

AMI

Language

AWS X-Ray

Proxy Server

Go 1 AL2 version 3.8.1

64bit Amazon Linux 2 v3.8.1 running Go 1

2.0.20230926

Go 1.21.2

3.2.0

nginx 1.22.1

Java SE

Platform Version and Solution Stack Name

AMI

Language

Tools

AWS X-Ray

Proxy Server

Corretto 17 AL2023 version 4.0.1

64bit Amazon Linux 2023 v4.0.1 running Corretto 17

2023.1.20230825

Corretto 17.0.8.7.1

Ant 1.10.12, Gradle 8.3, Maven 3.8.4

3.2.0

nginx 1.24.0

Corretto 17 version 3.5.1

64bit Amazon Linux 2 v3.5.1 running Corretto 17

2.0.20230926

Corretto 17.0.8.8.1

Ant 1.10.14, Gradle 8.4, Maven 3.8.8

3.2.0

nginx 1.22.1

Corretto 11 version 3.5.1

64bit Amazon Linux 2 v3.5.1 running Corretto 11

2.0.20230926

Corretto 11.0.20.9.1

Ant 1.10.14, Gradle 8.4, Maven 3.8.8

3.2.0

nginx 1.22.1

Corretto 8 version 3.5.1

64bit Amazon Linux 2 v3.5.1 running Corretto 8

2.0.20230926

Corretto 8.382.05.1

Ant 1.10.14, Gradle 8.4, Maven 3.8.8

3.2.0

nginx 1.22.1

Tomcat

Platform Version and Solution Stack Name

AMI

Language

AWS X-Ray

Application Server

Proxy Server

Corretto 17 with Tomcat 10 AL2023 version 5.0.2

64bit Amazon Linux 2023 v5.0.2 running Tomcat 10 Corretto 17

2023.1.20230825

Corretto 17.0.8.7.1

3.2.0

Tomcat 10.1.13

nginx 1.24.0 (default), Apache 2.4.56

Corretto 11 with Tomcat 8.5 AL2 version 4.3.12

64bit Amazon Linux 2 v4.3.12 running Tomcat 8.5 Corretto 11

2.0.20230926

Corretto 11.0.20.9.1

3.2.0

Tomcat 8.5.93

nginx 1.22.1 (default), Apache 2.4.57

Corretto 8 with Tomcat 8.5 AL2 version 4.3.12

64bit Amazon Linux 2 v4.3.12 running Tomcat 8.5 Corretto 8

2.0.20230926

Corretto 8.382.05.1

3.2.0

Tomcat 8.5.93

nginx 1.22.1 (default), Apache 2.4.57

.NET Core on Linux

Platform Version and Solution Stack Name

Framework

Proxy Server

AMI

AWS X-Ray

.NET Core on AL2 version 2.6.0

64bit Amazon Linux 2 v2.6.0 running .NET Core

.NET 6.0.22, supports 6.0.22

nginx 1.22.1

2.0.20230926

3.2.0

Node.js

Platform Version and Solution Stack Name

AMI

Node.js versions (npm versions)

Proxy Server

Git

AWS X-Ray

Node.js 18 AL2023 version 6.0.1

64bit Amazon Linux 2023 v6.0.1 running Node.js 18

2023.1.20230825

18.12.1 (8.19.2)

Default version: 18.12.1

nginx 1.24.0 (default), Apache 2.4.56

2.40.1

3.2.0

Node.js 18 AL2 version 5.8.6

64bit Amazon Linux 2 v5.8.6 running Node.js 18

2.0.20230926

18.18.0 (9.8.1), 18.17.1 (9.6.7), 18.17.0 (9.6.7), 18.16.1 (9.5.1), 18.16.0 (9.5.1), 18.15.0 (9.5.0), 18.14.2 (9.5.0), 18.14.1 (9.3.1), 18.14.0 (9.3.1), 18.13.0 (8.19.3), 18.12.1 (8.19.2), 18.12.0 (8.19.2), 18.11.0 (8.19.2), 18.10.0 (8.19.2), 18.9.1 (8.19.1), 18.9.0 (8.19.1), 18.8.0 (8.18.0), 18.7.0 (8.15.0), 18.6.0 (8.13.2), 18.5.0 (8.12.1), 18.4.0 (8.12.1), 18.3.0 (8.11.0), 18.2.0 (8.9.0), 18.1.0 (8.8.0), 18.0.0 (8.6.0)

Default version: 18.18.0

nginx 1.22.1 (default), Apache 2.4.57

2.40.1

3.2.0

PHP

Platform Version and Solution Stack Name

AMI

Language

Composer

Proxy Server

PHP 8.2 AL2023 version 4.0.1

64bit Amazon Linux 2023 v4.0.1 running PHP 8.2

2023.1.20230825

PHP 8.2.7

2.5.8

nginx 1.24.0 (default), Apache 2.4.56

PHP 8.1 AL2023 version 4.0.1

64bit Amazon Linux 2023 v4.0.1 running PHP 8.1

2023.1.20230825

PHP 8.1.22

2.5.7

nginx 1.24.0 (default), Apache 2.4.56

PHP 8.1 AL2 version 3.5.12

64bit Amazon Linux 2 v3.5.12 running PHP 8.1

2.0.20230926

PHP 8.1.24

2.3.5

nginx 1.22.1 (default), Apache 2.4.57

PHP 8.0 AL2 version 3.5.12

64bit Amazon Linux 2 v3.5.12 running PHP 8.0

2.0.20230926

PHP 8.0.30

2.0.13

nginx 1.22.1 (default), Apache 2.4.57

Python

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Packager

meld3

AWS X-Ray

Proxy Server

Python 3.11 AL2023 version 4.0.4

64bit Amazon Linux 2023 v4.0.4 running Python 3.11

2023.1.20230825

Python 3.11.2

pipenv 2023.8.26

3.2.0

nginx 1.24.0 (default), Apache 2.4.56

Python 3.9 AL2023 version 4.0.4

64bit Amazon Linux 2023 v4.0.4 running Python 3.9

2023.1.20230825

Python 3.9.16

pipenv 2023.8.26

3.2.0

nginx 1.24.0 (default), Apache 2.4.56

Python 3.8 AL2 version 3.5.7

64bit Amazon Linux 2 v3.5.7 running Python 3.8

2.0.20230926

Python 3.8.16

pipenv 2023.10.3

3.2.0

nginx 1.22.1 (default), Apache 2.4.57

Ruby

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X-Ray

Proxy Server

Ruby 3.0 AL2 version 3.6.12

64bit Amazon Linux 2 v3.6.12 running Ruby 3.0

2.0.20230926

Ruby 3.0.6-p216

RubyGems 3.4.20

Puma 6.4.0

3.2.0

nginx 1.22.1