Actualizaciones del motor de base de datos de Aurora MySQL del 29/05/2019 (versión 2.04.4) (obsoleta) - Amazon Aurora

Las traducciones son generadas a través de traducción automática. En caso de conflicto entre la traducción y la version original de inglés, prevalecerá la version en inglés.

Actualizaciones del motor de base de datos de Aurora MySQL del 29/05/2019 (versión 2.04.4) (obsoleta)

version: 2.04.4

Aurora MySQL 2.04.4 ya está disponible con carácter general. Las versiones 2.x de Aurora MySQL son compatibles con MySQL 5.7 y las versiones 1.x de Aurora MySQL son compatibles con MySQL 5.6.

Las versiones de Aurora MySQL compatibles actualmente son: 1.19.5, 1.19.6, 1.22.*, 1.23.*, 2.04.*, 2.07.*, 2.08.*, 2,09.*, 2.10.*, 3.01.* y 3.02.*.

Al crear un nuevo clúster de base de datos de Aurora MySQL (incluida la restauración de instantáneas), tiene la opción de elegir la compatibilidad con MySQL 5.7 o MySQL 5.6. No permitimos la actualización in situ de los clústeres de Aurora MySQL 1.* ni la restauración de clústeres Aurora MySQL 1.* desde una copia de seguridad de Amazon S3 en Aurora MySQL 2.04.4. Tenemos previsto quitar estas restricciones en una versión posterior de Aurora MySQL 2.*.

Puede restaurar instantáneas de Aurora MySQL 1.14.*, 1.15.*, 1.16.*, 1.17.*, 1.18.*, 1.19.*, 2.01.*, 2.02.*, 2.03.* y 2.04* en Aurora MySQL 2.04.4.

Si tiene alguna pregunta o duda, el servicio de AWS asistencia está disponible en los foros de la comunidad y a través de AWS Support. Para obtener más información, consulte Mantenimiento de un clúster de base de datos de Amazon Aurora en la Guía del usuario de Amazon Aurora.

nota

Actualmente, esta versión no está disponible en las regiones AWS GovCloud (EE. UU. Oeste) [us-gov-west-1], Europa (Estocolmo) [eu-north-1], China (Ningxia) [cn-northwest-1] y Asia Pacífico (Hong Kong) [ap-east-1]. AWS Cuando esté disponible, enviaremos una notificación aparte.

nota

Para obtener información sobre cómo actualizar el clúster de base de datos de Aurora MySQL, consulte Actualización de la versión secundaria o el nivel de parche de un clúster de bases de datos Aurora MySQL en la Guía del usuario de Amazon Aurora.

Mejoras

  • Se ha solucionado un problema que podía causar errores al cargar datos en Aurora desde S3.

  • Se ha solucionado un problema que podía causar errores al cargar datos de Aurora en S3.

  • Se ha solucionado un problema que provocaba anulaciones de conexiones cuando se gestionaba un error en la administración de protocolos de red.

  • Se ha solucionado un problema que podía provocar un bloqueo cuando se trabajaba con tablas particionadas.

  • Se ha solucionado un problema con la característica de información sobre rendimiento, que no estaba disponible en algunas regiones.

Comparación con Aurora MySQL, versión 1

Las siguientes características de Amazon Aurora MySQL se admiten en Aurora MySQL, versión 1 (compatible con MySQL 5.6), pero esas características no se admiten en Aurora MySQL, versión 2 (compatible con MySQL 5.7).

Compatibilidad de MySQL 5.7

Aurora MySQL 2.04.4 es compatible con cables con MySQL 5.7 e incluye características como la compatibilidad con JSON, índices espaciales y columnas generadas. Aurora MySQL usa una implementación nativa de la indexación espacial mediante curvas de orden z para multiplicar por más de 20 el rendimiento de escritura y por más de 10 el rendimiento de lectura en comparación con MySQL 5.7 para conjuntos espaciales.

Aurora MySQL 2.04.4 no admite actualmente las siguientes características de MySQL 5.7:

  • Complemento de replicación de grupo

  • Tamaño de página incrementado

  • Carga de grupo de búfer de InnoDB al inicio

  • Complemento de analizador de texto completo de InnoDB

  • Replicación de varios orígenes

  • Cambio de tamaño de grupo de búfer online

  • Complemento de validación de contraseñas

  • Complementos de reescritura de consulta

  • Filtrado de replicación

  • La instrucción SQL CREATE TABLESPACE