Actualizaciones del motor de base de datos de Aurora MySQL del 19/09/2019 (versión 2.04.6) (obsoleta) - Amazon Aurora

Las traducciones son generadas a través de traducción automática. En caso de conflicto entre la traducción y la version original de inglés, prevalecerá la version en inglés.

Actualizaciones del motor de base de datos de Aurora MySQL del 19/09/2019 (versión 2.04.6) (obsoleta)

Versión: 2.04.6

Aurora MySQL 2.04.6 ya está disponible con carácter general. Las versiones 2.x de Aurora MySQL son compatibles con MySQL 5.7 y las versiones 1.x de Aurora MySQL son compatibles con MySQL 5.6.

Las versiones de Aurora MySQL compatibles actualmente son: 1.19.5, 1.19.6, 1.22.*, 1.23.*, 2.04.*, 2.07.*, 2.08.*, 2,09.*, 2.10.*, 3.01.* y 3.02.*.

Tiene la opción de actualizar los clústeres de base de datos Aurora MySQL 2.* existentes a Aurora MySQL 2.04.6. No permitimos la actualización in situ de clústeres de Aurora MySQL 1.*. Esta restricción se aplicará en las versiones posteriores de Aurora MySQL 2.*. Puede restaurar instantáneas de Aurora MySQL 1.14.*, 1.15.*, 1.16.*, 1.17.*, 1.18.*, 1.19.*, 2.01.*, 2.02.*, 2.03.* y 2.04.* en Aurora MySQL 2.04.6.

Para usar una versión anterior de Aurora MySQL, puede crear nuevos clústeres de bases de datos especificando la versión del motor a través de la AWS Management Console AWS CLI, la o la API de Amazon RDS.

Si tiene alguna pregunta o duda, el servicio de AWS asistencia está disponible en los foros de la comunidad y a través de AWS Support. Para obtener más información, consulte Mantenimiento de un clúster de base de datos de Amazon Aurora en la Guía del usuario de Amazon Aurora.

nota

Actualmente, esta versión no está disponible en las siguientes AWS regiones: Europa (Londres) [eu-west-2], AWS GovCloud (US-Este) [us-gov-east-1], (US-Oeste) [-1], China AWS GovCloud (Ningxia) [us-gov-westcn-northwest-1] y Asia Pacífico (Hong Kong) [ap-east-1]. Cuando esté disponible, enviaremos una notificación aparte.

nota

Para obtener información sobre cómo actualizar el clúster de base de datos de Aurora MySQL, consulte Actualización de la versión secundaria o el nivel de parche de un clúster de bases de datos Aurora MySQL en la Guía del usuario de Amazon Aurora.

Mejoras

  • Se ha corregido un problema por el cual los eventos en el archivo binlog actual en el principal no se replicaban en el nodo de trabajo si el valor del parámetro sync_binlog no se configuraba en 1.

  • El valor predeterminado del parámetro aurora_binlog_replication_max_yield_seconds ha cambiado a cero para evitar un aumento en el retardo de la replicación en favor del rendimiento de consultas de primer plano en el maestro de binlog.

Integración de correcciones de errores de MySQL.

  • Error #23054591: PURGE BINARY LOGS TO está leyendo todo el archivo binlog y provoca el bloqueo MySql

Comparación con Aurora MySQL, versión 1

Las siguientes características de Amazon Aurora MySQL se admiten en Aurora MySQL, versión 1 (compatible con MySQL 5.6), pero esas características no se admiten en Aurora MySQL, versión 2 (compatible con MySQL 5.7).

Compatibilidad de MySQL 5.7

Aurora MySQL 2.04.6 es compatible con cables con MySQL 5.7 e incluye características como la compatibilidad con JSON, índices espaciales y columnas generadas. Aurora MySQL usa una implementación nativa de la indexación espacial mediante curvas de orden z para multiplicar por más de 20 el rendimiento de escritura y por más de 10 el rendimiento de lectura en comparación con MySQL 5.7 para conjuntos espaciales.

Aurora MySQL 2.04.6 no admite actualmente las siguientes características de MySQL 5.7:

  • Complemento de replicación de grupo

  • Tamaño de página incrementado

  • Carga de grupo de búfer de InnoDB al inicio

  • Complemento de analizador de texto completo de InnoDB

  • Replicación de varios orígenes

  • Cambio de tamaño de grupo de búfer online

  • Complemento de validación de contraseñas

  • Complementos de reescritura de consulta

  • Filtrado de replicación

  • La instrucción SQL CREATE TABLESPACE