Instalar, actualizar y desinstalar la AWS CLI - AWS Command Line Interface

Esta documentación es para la versión 1 de AWS CLI. Para obtener documentación relacionada con la versión 2 de AWS CLI, consulte la Guía del usuario de la versión 2.

Instalar, actualizar y desinstalar la AWS CLI

En este tema, se proporcionan enlaces para instalar, actualizar y desinstalar la versión original de AWS Command Line Interface (AWS CLI). La versión 1 de AWS CLI es compatible actualmente, pero se agregan nuevas características a la versión 2 de AWS CLI que puede que no se agreguen a la versión 1 de AWS CLI. Para utilizar estas características, debe instalar la versión 2 de la AWS CLI. Para obtener información sobre cómo instalar la versión 2, consulte Instalación de la versión 2 de AWS CLI.

Instrucciones de instalación, actualización y desinstalación de AWS CLI:

Requisitos de versión de Python

La versión 1 de la AWS CLI se construye usando el SDK para Python y, por lo tanto, requiere que instale una versión compatible de Python.

Matriz de compatibilidad con versiones de Python
Version de la AWS CLI Versión de Python compatible
1.20.0 – actual Python 3.6+
1.19.0 – 1.19.x Python: Python 3.6 y 2.7
1.17 – 1.18.x Python 2.7+, Python 3.4+
1.0 – 1.16.x Python 2.6 y versiones anteriores, Python 3.3 y versiones anteriores