Version : mises à jour de plateforme Amazon Linux 2 pour Elastic Beanstalk le 30 juin 2023 - AWS Elastic Beanstalk

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Version : mises à jour de plateforme Amazon Linux 2 pour Elastic Beanstalk le 30 juin 2023

Cette version fournit de nouvelles versions pour les plateformes AWS Elastic Beanstalk basées sur Amazon Linux 2. La version inclut des mises à jour de sécurité. Elle comprend également des mises à jour d'AMI, de Docker basées sur ECS, de Go, de Tomcat, de .NET Core, de Node.js, de PHP, de Python et de Ruby.

Date de parution : 30 juin 2023

Modifications

Le tableau suivant répertorie les modifications incluses dans cette version.

Remarques
  • Ces notes de mise à jour se concentrent sur les modifications apportées aux branches de plateforme actuellement prises en charge. Pour des informations complètes sur les branches de plateforme Elastic Beanstalk mises hors service (obsolètes), consultez Versions de plateforme Elastic Beanstalk planifiées pour une mise hors service dans le guide Plateformes AWS Elastic Beanstalk.

  • Sachez qu'au moment de la publication de ces notes de mise à jour, les nouvelles versions de plateforme peuvent ne pas encore être disponibles dans toutes les régions AWS prises en charge par Elastic Beanstalk. Plusieurs heures peuvent encore être nécessaires pour terminer la version.

Catégorie Description

Mises à jour de sécurité

Application de toutes les mises à jour de sécurité publiées dans le centre de sécurité Amazon Linux (français non garanti) au plus tard le 27 juin 2023 à toutes les plateformes Amazon Linux 2.

Certaines des mises à jour de plateforme sont des versions de sécurité. Pour de plus amples informations, veuillez consulter Mises à jour spécifiques à une plateforme dans ce tableau.

Mises à jour multiplateformes

Application de ces mises à jour multiplateformes :

Composant Mettre à jour

AMI

Mise à jour de l'AMI de base vers la version 2.0.20230612.

Mises à jour spécifiques aux plateformes

Application de ces mises à jour spécifiques aux plateformes :

Plateforme Mettre à jour

Docker

Mise à jour de l'agent Amazon ECS vers la version 1.72.0 sur la branche de plateforme ECS Amazon Linux 2.

Go

Mise à jour de Go vers la version 1.20.5. Pour plus de détails, consultez go1.20.5 dans l'Historique des versions de langage de programmation Go (français non garanti).

Il s'agit d'une version de sécurité.

La version Go 1.20.5 est une version de sécurité.

Tomcat

Mise à jour de Tomcat 8.5 vers Tomcat 8.5.89.

.NET Core

Mise à jour de .NET Core vers la version 6.0.19.

Node.js

Mise à jour de Node.js 18 pour ajouter la prise en charge de la version 18.16.1 de Node.

Mise à jour de Node.js 16 pour ajouter la prise en charge de la version 16.20.1 de Node.

Les nouvelles mises à jour de Node.js sont des versions de sécurité.

PHP

Mise à jour de PHP 8.1 vers la version 8.1.20.

Cette mise à jour est une version de sécurité.

Python

Mise à jour de Pipenv vers la version 2023.6.26. Pour plus de détails, consultez Historique des versions de Pipenv.

Ruby

Mise à jour de RubyGems vers la version 3.4.14. Pour plus de détails, consultez la section sur la version 3.4.14 du blog RubyGems (français non garanti).

Mise à jour de Puma vers la version 6.3.0.

Nouvelles versions de plateforme

Note

Les tableaux suivants répertorient toutes les branches de plateforme prises en charge pour chaque plateforme. Seules les branches de la plateforme Amazon Linux 2 sont mises à jour.

Docker

Version de plateforme et Nom de la pile de solutions

AMI

Agent ECS

Docker

Docker Compose

Serveur proxy

Docker AL2 version 3.5.9

64bit Amazon Linux 2 v3.5.9 running Docker

2.0.20230612

20.10.23-1

1.29.2

nginx 1.22.1

 ECS AL2 version 3.2.9

64bit Amazon Linux 2 v3.2.9 running ECS

2.0.20230612

1.72.0

Go

Version de plateforme et Nom de la pile de solutions

AMI

Langage

AWS X-Ray

Serveur proxy

Go 1 AL2 version 3.7.4

64bit Amazon Linux 2 v3.7.4 running Go 1

2.0.20230612

Go 1.20.5

3.2.0

nginx 1.22.1

Java SE

Version de plateforme et Nom de la pile de solutions

AMI

Langage

Outils

AWS X-Ray

Serveur proxy

Corretto 17 version 3.4.9

64bit Amazon Linux 2 v3.4.9 running Corretto 17

2.0.20230612

Corretto 17.0.7.7.1

Ant 1.10.7, Gradle 7.4.2, Maven 3.6.2

3.2.0

nginx 1.22.1

Corretto 11 version 3.4.9

64bit Amazon Linux 2 v3.4.9 running Corretto 11

2.0.20230612

Corretto 11.0.19.7.1

Ant 1.10.7, Gradle 5.6.2, Maven 3.6.2

3.2.0

nginx 1.22.1

Corretto 8 version 3.4.9

64bit Amazon Linux 2 v3.4.9 running Corretto 8

2.0.20230612

Corretto 8.372.07.1

Ant 1.10.7, Gradle 5.6.2, Maven 3.6.2

3.2.0

nginx 1.22.1

Tomcat

Version de plateforme et Solution Stack Name (Nom de la pile de solutions)

AMI

Langage

AWS X-Ray

Serveur d'application

Serveur proxy

Corretto 11 with Tomcat 8.5 AL2 version 4.3.9

64bit Amazon Linux 2 v4.3.9 running Tomcat 8.5 Corretto 11

2.0.20230612

Corretto 11.0.19.7.1

3.2.0

Tomcat 8.5.89

nginx 1.22.1 (par défaut), Apache 2.4.57

Corretto 8 with Tomcat 8.5 AL2 version 4.3.9

64bit Amazon Linux 2 v4.3.9 running Tomcat 8.5 Corretto 8

2.0.20230612

Corretto 8.372.07.1

3.2.0

Tomcat 8.5.89

nginx 1.22.1 (par défaut), Apache 2.4.57

.NET Core sous Linux

Version de plateforme et Nom de la pile de solutions

Cadre

Serveur proxy

AMI

AWS X-Ray

.NET Core on AL2 version 2.5.5

64bit Amazon Linux 2 v2.5.5 running .NET Core

.NET 6.0.19, prend en charge 6.0.19, 3.1.32

nginx 1.22.1

2.0.20230612

3.2.0

Node.js

Version de plateforme et Nom de la pile de solutions

AMI

Versions Node.js (versions npm)

Serveur proxy

Git

AWS X-Ray

Node.js 18 AL2 version 5.8.3

64bit Amazon Linux 2 v5.8.3 running Node.js 18

2.0.20230612

18.16.1 (9.5.1), 18.16.0 (9.5.1), 18.15.0 (9.5.0), 18.14.2 (9.5.0), 18.14.1 (9.3.1), 18.14.0 (9.3.1), 18.13.0 (8.19.3), 18.12.1 (8.19.2), 18.12.0 (8.19.2), 18.11.0 (8.19.2), 18.10.0 (8.19.2), 18.9.1 (8.19.1), 18.9.0 (8.19.1), 18.8.0 (8.18.0), 18.7.0 (8.15.0), 18.6.0 (8.13.2), 18.5.0 (8.12.1), 18.4.0 (8.12.1), 18.3.0 (8.11.0), 18.2.0 (8.9.0), 18.1.0 (8.8.0), 18.0.0 (8.6.0)

Version par défaut : 18.16.1

nginx 1.22.1 (par défaut), Apache 2.4.57

2.40.1

3.2.0

Node.js 16 AL2 version 5.8.3

64bit Amazon Linux 2 v5.8.3 running Node.js 16

2.0.20230612

16.20.1 (8.19.4), 16.20.0 (8.19.4), 16.19.1 (8.19.3), 16.19.0 (8.19.3), 16.18.1 (8.19.2), 16.18.0 (8.19.2), 16.17.1 (8.15.0), 16.17.0 (8.15.0), 16.16.0 (8.11.0), 16.15.1 (8.11.0), 16.15.0 (8.5.5), 16.14.2 (8.5.0), 16.14.1 (8.5.0), 16.14.0 (8.3.1), 16.13.2 (8.1.2), 16.13.1 (8.1.2), 16.13.0 (8.1.0), 16.12.0 (8.1.0), 16.11.1 (8.0.0), 16.11.0 (8.0.0), 16.10.0 (7.24.0), 16.9.1 (7.21.1), 16.9.0 (7.21.1), 16.8.0 (7.21.0), 16.7.0 (7.20.3), 16.6.2 (7.20.3), 16.6.1 (7.20.3), 16.6.0 (7.19.1), 16.5.0 (7.19.1), 16.4.2 (7.18.1), 16.4.1 (7.18.1), 16.4.0 (7.18.1), 16.3.0 (7.15.1), 16.2.0 (7.13.0), 16.1.0 (7.11.2), 16.0.0 (7.10.0)

Version par défaut : 16.20.1

nginx 1.22.1 (par défaut), Apache 2.4.57

2.40.1

3.2.0

Node.js 14 AL2 version 5.8.3

64bit Amazon Linux 2 v5.8.3 running Node.js 14

2.0.20230612

14.21.3 (6.14.18), 14.21.2 (6.14.17), 14.21.1 (6.14.17), 14.21.0 (6.14.17), 14.20.1 (6.14.17), 14.20.0 (6.14.17), 14.19.3 (6.14.17), 14.19.2 (6.14.17), 14.19.1 (6.14.16), 14.19.0 (6.14.16), 14.18.3 (6.14.15), 14.18.2 (6.14.15), 14.18.1 (6.14.15), 14.18.0 (6.14.15), 14.17.6 (6.14.15), 14.17.5 (6.14.14), 14.17.4 (6.14.14), 14.17.3 (6.14.13), 14.17.2 (6.14.13), 14.17.1 (6.14.13), 14.17.0 (6.14.13), 14.16.1 (6.14.12), 14.16.0 (6.14.11), 14.15.5 (6.14.11), 14.15.4 (6.14.10), 14.15.3 (6.14.9), 14.15.2 (6.14.9), 14.15.1 (6.14.8), 14.15.0 (6.14.8), 14.14.0 (6.14.8), 14.13.1 (6.14.8), 14.13.0 (6.14.8), 14.12.0 (6.14.8), 14.11.0 (6.14.8), 14.10.1 (6.14.8), 14.10.0 (6.14.8), 14.9.0 (6.14.8), 14.8.0 (6.14.7), 14.7.0 (6.14.7), 14.6.0 (6.14.6), 14.5.0 (6.14.5), 14.4.0 (6.14.5), 14.3.0 (6.14.5), 14.2.0 (6.14.4), 14.1.0 (6.14.4), 14.0.0 (6.14.4)

Version par défaut : 14.21.3

nginx 1.22.1 (par défaut), Apache 2.4.57

2.40.1

3.2.0

PHP

Version de plateforme et Solution Stack Name (Nom de la pile de solutions)

AMI

Langage

Composer

Serveur proxy

PHP 8.1 AL2 version 3.5.9

64bit Amazon Linux 2 v3.5.9 running PHP 8.1

2.0.20230612

PHP 8.1.20

2.3.5

nginx 1.22.1 (par défaut), Apache 2.4.57

PHP 8.0 AL2 version 3.5.9

64bit Amazon Linux 2 v3.5.9 running PHP 8.0

2.0.20230612

PHP 8.0.28

2.0.13

nginx 1.22.1 (par défaut), Apache 2.4.57

Python

Version de plateforme et Solution Stack Name (Nom de la pile de solutions)

AMI

Langage

Gestionnaire de package

Outil de création de package

meld3

AWS X-Ray

Serveur proxy

Python 3.8 AL2 version 3.5.4

64bit Amazon Linux 2 v3.5.4 running Python 3.8

2.0.20230612

Python 3.8.16

pipenv 2023.6.26

3.2.0

nginx 1.22.1 (par défaut), Apache 2.4.57

Python 3.7 AL2 version 3.5.4

64bit Amazon Linux 2 v3.5.4 running Python 3.7

2.0.20230612

Python 3.7.16

pipenv 2023.6.26

3.2.0

nginx 1.22.1 (par défaut), Apache 2.4.57

Ruby

Version de plateforme et Solution Stack Name (Nom de la pile de solutions)

AMI

Langage

Gestionnaire de package

Serveur d'application

AWS X-Ray

Serveur proxy

Ruby 3.0 AL2 version 3.6.9

64bit Amazon Linux 2 v3.6.9 running Ruby 3.0

2.0.20230612

Ruby 3.0.6-p216

RubyGems 3.4.14

Puma 6.3.0

3.2.0

nginx 1.22.1

Ruby 2.7 AL2 version 3.6.9

64bit Amazon Linux 2 v3.6.9 running Ruby 2.7

2.0.20230612

Ruby 2.7.8-p225

RubyGems 3.4.14

Puma 6.3.0

3.2.0

nginx 1.22.1