Moteur Amazon Neptune version 1.0.4.2.R4 (2021-07-23) - Amazon Neptune

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Moteur Amazon Neptune version 1.0.4.2.R4 (2021-07-23)

Depuis 2021-07-23, la version 1.0.4.2.R4 du moteur est généralement déployée. Veuillez noter que plusieurs jours sont nécessaires pour qu’une nouvelle version soit disponible dans chaque région.

Améliorations de cette version du moteur

  • Amélioration du comportement du cache de recherche pour éviter l'effacement redondant du cache après avoir exécuté une réinitialisation rapide sur un réplica.

  • Gestion améliorée des journaux de modification en continu lorsqueAFTER_SEQUENCE_NUMBERles flux sont demandés avec le dernier ID d'événement sur le serveur, lorsque cet ID d'événement a déjà expiré. Le serveur ne génère plus d'erreur d'ID d'événement expiré si l'ID d'événement demandé est le dernier ID d'événement purgé sur le serveur.

Défauts corrigés dans cette version du moteur

  • Correction d'un bogue introduit dans 1.0.4.0.R1 où les requêtes ne renvoyaient pas l'intégralité des valeurs de chaîne supérieures à 760 caractères. Les termes affectés par ce bogue étaient des littéraux RDF et des URI, ou des identifiants Gremlin, des clés et des valeurs de chaîne.

Versions en langage de requête prises en charge dans cette version

Avant de mettre à niveau un cluster de bases de données vers la version 1.0.4.2.R4, assurez-vous que votre projet est compatible avec ces versions en langage de requête :

  • Version Gremlin : 3.4.10

  • Version SPARQL : 1.1

Chemins de mise à niveau vers la version 1.0.4.2.R4 du moteur

Votre cluster sera automatiquement mis à niveau vers cette version de correctif lors de votre prochaine fenêtre de maintenance si vous exécutez la version de moteur 1.0.4.2.

Vous pouvez mettre à niveau manuellement n'importe quelle version précédente du moteur Neptune vers cette version.