Aurora Serverless v1 및 Aurora 데이터베이스 엔진 버전 - Amazon Aurora

Aurora Serverless v1 및 Aurora 데이터베이스 엔진 버전

Aurora Serverless v1은 특정 AWS 리전와 특정 Aurora MySQL 및 Aurora PostgreSQL 버전에서만 사용할 수 있습니다. AWS 리전을 지원하는 Aurora Serverless v1의 최신 목록과 각 리전에서 사용할 수 있는 특정 Aurora MySQL 및 Aurora PostgreSQL 버전은 Aurora Serverless v1 섹션을 참조하세요.

Aurora Serverless v1은 연결된 Aurora 데이터베이스 엔진을 사용하여 지원되는 각 데이터베이스 엔진별로 지원되는 특정 릴리스를 식별합니다.

  • Aurora MySQL Serverless

  • Aurora PostgreSQL Serverless

Aurora Serverless v1용으로 데이터베이스 엔진의 마이너 릴리스가 제공되면 AWS 리전를 사용할 수 있는 다양한 Aurora Serverless v1에서 자동으로 적용됩니다. 즉, Aurora Serverless v1용으로 제공되는 클러스터 DB 엔진에 대한 새 마이너 릴리스를 얻기 위해 Aurora Serverless v1 DB 클러스터를 업그레이드할 필요가 없습니다.

Aurora MySQL Serverless

Aurora Serverless은 특정 AWS 리전와 특정 Aurora MySQL 및 Aurora PostgreSQL 버전에서만 사용할 수 있습니다. AWS 리전을 지원하는 Aurora Serverless의 최신 목록과 각 리전에서 사용할 수 있는 특정 Aurora MySQL 및 Aurora PostgreSQL 버전은 Aurora Serverless v1 섹션을 참조하세요.

Aurora Serverless은 연결된 Aurora 데이터베이스 엔진을 사용하여 지원되는 각 데이터베이스 엔진별로 지원되는 특정 릴리스를 식별합니다.

  • Aurora MySQL Serverless

  • Aurora PostgreSQL Serverless

Aurora Serverless용으로 데이터베이스 엔진의 마이너 릴리스가 제공되면 AWS 리전를 사용할 수 있는 다양한 Aurora Serverless에서 자동으로 적용됩니다. 즉, Aurora Serverless용으로 제공되는 클러스터 DB 엔진에 대한 새 마이너 릴리스를 얻기 위해 Aurora Serverless DB 클러스터를 업그레이드할 필요가 없습니다.

Aurora MySQL Serverless

Aurora Serverless DB 클러스터에 대한 Aurora MySQL 호환 버전을 사용하려면 Aurora MySQL 5.6 호환 버전 또는 Aurora MySQL 5.7 호환 버전 중에서 선택할 수 있습니다. 이 두 가지 Aurora MySQL 버전은 크게 다릅니다. 사용 사례에 맞게 선택할 수 있도록 Aurora Serverless DB 클러스터를 생성하기 전에 차이점을 비교하는 것이 좋습니다. Aurora MySQL Serverless 5.6 및 5.7의 향상된 기능 및 버그 수정에 대한 자세한 내용은 Aurora MySQL 릴리스 정보Aurora Serverless 클러스터에 대한 데이터베이스 엔진 업데이트를 참조하세요.

Aurora PostgreSQL Serverless

Aurora Serverless DB 클러스터에 Aurora PostgreSQL을 사용하려는 경우 단일 버전을 사용할 수 있습니다. Aurora PostgreSQL 호환 버전의 마이너 릴리스에는 이전 버전과 호환되는 변경 사항만 포함됩니다. Aurora Serverless DB 클러스터는 해당 리전에서 Aurora Serverless에 Aurora PostgreSQL 마이너 릴리스를 사용할 수 있게 되면 자동으로 업그레이드됩니다.

예를 들어 마이너 버전 Aurora PostgreSQL 10.14 릴리스는 이전 Aurora PostgreSQL 버전을 실행하는 모든 Aurora Serverless DB 클러스터에 자동으로 적용되었습니다. Aurora PostgreSQL 버전 10.14 업데이트에 대한 자세한 내용은 Aurora PostgreSQL 릴리스 정보PostgreSQL 10.14, Aurora PostgreSQL 릴리스 2.7을 참조하세요.

Aurora PostgreSQL Serverless

Aurora Serverless v1 DB 클러스터에 Aurora PostgreSQL을 사용하려는 경우 단일 버전을 사용할 수 있습니다. Aurora PostgreSQL 호환 버전의 마이너 릴리스에는 이전 버전과 호환되는 변경 사항만 포함됩니다. Aurora Serverless v1 DB 클러스터는 해당 리전에서 Aurora Serverless v1에 Aurora PostgreSQL 마이너 릴리스를 사용할 수 있게 되면 자동으로 업그레이드됩니다.

예를 들어 마이너 버전 Aurora PostgreSQL 10.14 릴리스는 이전 Aurora PostgreSQL 버전을 실행하는 모든 Aurora Serverless v1 DB 클러스터에 자동으로 적용되었습니다. Aurora PostgreSQL 버전 10.14 업데이트에 대한 자세한 내용은 Aurora PostgreSQL 릴리스 정보PostgreSQL 10.14, Aurora PostgreSQL 릴리스 2.7을 참조하세요.