AWS Lambda
개발자 가이드

API 참조

이 단원은 AWS Lambda API 참조 문서를 포함합니다. API 호출 시 서명을 제공하여 요청을 인증해야 합니다. AWS Lambda는 서명 버전 4를 지원합니다. 자세한 내용은 Amazon Web Services 일반 참조서명 버전 4 서명 프로세스 단원을 참조하십시오.

서비스에 대한 개요는 AWS Lambda란 무엇입니까? 단원을 참조하십시오.

AWS CLI를 사용하여 AWS Lambda API를 탐색할 수 있습니다. 이 가이드는 를 사용하는 몇 가지 자습서를 제공합니다.

주제

SDK를 사용할 때의 인증서 오류

AWS SDK는 컴퓨터의 CA 인증서를 사용하기 때문에, AWS 서버의 인증서가 변경되면 SDK를 사용하려고 할 때 연결 장애가 발생할 수 있습니다. 컴퓨터의 CA 인증서와 운영 체제를 최신 상태로 유지하여 이러한 장애를 피할 수 있습니다. 본인 컴퓨터를 직접 관리하지 않는 기업 환경에서 이 문제가 발생하는 경우, 관리자에게 업데이트 프로세스를 문의해야 할 수 있습니다. 아래 목록에 최소한의 운영 체제 및 Java 버전이 나와 있습니다.

  • 2005년 1월 이후 업데이트가 설치된 Microsoft Windows 버전의 경우, 신뢰할 수 있는 연결 목록에 필요한 CA가 하나 이상 들어 있습니다.

  • Mac OS X 10.4 릴리스 5(2007년 2월), Mac OS X 10.5(2007년 10월) 및 그 이후 버전의 Java가 설치된 Mac OS X 10.4의 경우, 신뢰할 수 있는 연결 목록에 필요한 CA가 하나 이상 들어 있습니다.

  • Red Hat Enterprise Linux 5(2007년 3월), 6, 7과 CentOS 5, 6, 7은 모두 신뢰할 수 있는 기본 CA 목록에 필요한 CA가 하나 이상 들어 있습니다.

  • Java 1.4.2_12(2006년 5월), 5 업데이트 2(2005년 3월), 그리고 Java 6(2006년 12월), 7, 8을 포함한 이후의 모든 버전은 신뢰할 수 있는 기본 CA 목록에 필요한 CA가 하나 이상 들어 있습니다.

브라우저를 통해서든 프로그래밍 방식으로든 관계없이 AWS Lambda 관리 콘솔이나 AWS Lambda API 엔드포인트에 액세스할 때 클라이언트 머신에서 다음 CA를 지원하는지 확인해야 합니다.

  • Amazon Root CA 1

  • Starfield Services Root Certificate Authority - G2

  • Starfield Class 2 Certification Authority

처음 두 기관의 루트 인증서는 Amazon Trust Services에서 구할 수 있지만, 컴퓨터를 최신 상태로 유지하는 것이 보다 직접적인 해결책입니다. ACM 제공 인증서에 대한 자세한 내용은 AWS Certificate Manager FAQ를 참조하십시오.