Prerequisites for installing the MGN connector - Application Migration Service

Prerequisites for installing the MGN connector

Installing the MGN connector requires a dedicated Linux server. The MGN connector can be deployed on the same server that hosts the MGN vCenter Client installer (agentless appliance). This server should be used only for the MGN connector and MGN agentless appliance, and should not be used for any other purposes.

The MGN connector can be installed on servers running the following Linux versions:

  • Ubuntu 18.x+ (64 bit) - 22.04

  • AL2

  • RHEL8.x

In order to utilize AWS Application Migration Service connector, you must meet the following prerequisites:

  • openssl

The AWS MGN vCenter Client installer can only be installed on Ubuntu 18 64 bit, RHEL8 or AL2 VMs.

If the SSM agent is installed, it must be removed before installing the MGN connector. See Uninstalling SSM Agent from Linux instances in the AWS Systems Manager User Guide.

In addition, you must also have the required permissions.