Features by engine version - Amazon OpenSearch Service

Features by engine version

Many OpenSearch Service features have a minimum OpenSearch version requirement or legacy Elasticsearch OSS version requirement. If you meet the minimum version for a feature, but the feature isn't available on your domain, update your domain's service software.

Feature Minimum required OpenSearch version Minimum required Elasticsearch version

VPC support

1.0 1.0

Require HTTPS for all traffic to the domain

Multi-AZ support

Dedicated master nodes

Custom packages

Custom endpoints

Slow log publishing

Error log publishing

1.0 5.1

Encryption of data at rest

Cognito authentication for OpenSearch Dashboards

In-place upgrades

Curator support

Not included 5.1

Hourly automated snapshots

1.0 5.3

Node-to-node encryption

1.0 6.0

Java high-level REST client support

HTTP request and response compression

Alerting

1.0 6.2

SQL

1.0 6.5

Cross-cluster search

1.0 6.7

Fine-grained access control

SAML authentication for OpenSearch Dashboards

Auto-Tune

Remote reindex

UltraWarm

1.0 6.8

Index State Management

k-NN by Euclidean distance

1.0 7.1

Anomaly Detection

1.0 7.4

k-NN by cosine similarity

1.0 7.7

Learning to Rank

Piped processing language

1.0 7.9

OpenSearch Dashboards reports

OpenSearch Dashboards Trace Analytics

ARM-based Graviton instances

Cold storage

Hamming distance, L1 Norm distance, and Painless scripting for k-NN

1.0 7.10

Asynchronous search

Index transforms1.0Not included
Cross-cluster replication 1.1 7.10
ML Commons 1.3 Not included

For information about plugins, which enable some of these features and additional functionality, see Plugins by engine version. For information about the OpenSearch API for each version, see Supported operations.