Instalar, atualizar e desinstalar a AWS CLI - AWS Command Line Interface

Esta documentação é somente para a versão 1 da AWS CLI. Para obter a documentação relacionada à AWS CLI versão 2, consulte o Guia do usuário da versão 2.

Instalar, atualizar e desinstalar a AWS CLI

Este tópico fornece links para instalar, atualizar e desinstalar a versão original da AWS Command Line Interface(AWS CLI). A AWS CLI versão 1 atualmente é compatível, mas novos recursos adicionados à AWS CLI versão 2 não podem ser adicionados à AWS CLI versão 1. Para usar esses recursos, é necessário instalar a AWS CLI versão 2. Para obter mais informações sobre como instalar a versão 2, consulte Instalar a AWS CLI versão 2.

Instruções para instalar, atualizar e desinstalar a AWS CLI:

Requisitos da versão do Python

A AWS CLI versão 1 é criada com o SDK for Python e, portanto, requer a instalação de uma versão compatível do Python.

Matriz de suporte a versões do Python
AWS CLI versão do Versão do Python com suporte
1.19.0: atual Python 3.6
1.19.0: 1.19.x Python 2.7+, Python 3.6+
1.17 – 1.18.x Python 2.7+, Python 3.4+
1.0 – 1.16.x Python 2.6 e anteriores, Python 3.3 e anteriores