You are viewing documentation for version 3 of the AWS SDK for Ruby. Version 2 documentation can be found here.

Module: Aws::IAM::Errors

Defined in:
gems/aws-sdk-iam/lib/aws-sdk-iam/errors.rb

Defined Under Namespace

Classes: ConcurrentModificationException, CredentialReportExpiredException, CredentialReportNotPresentException, CredentialReportNotReadyException, DeleteConflictException, DuplicateCertificateException, DuplicateSSHPublicKeyException, EntityAlreadyExistsException, EntityTemporarilyUnmodifiableException, InvalidAuthenticationCodeException, InvalidCertificateException, InvalidInputException, InvalidPublicKeyException, InvalidUserTypeException, KeyPairMismatchException, LimitExceededException, MalformedCertificateException, MalformedPolicyDocumentException, NoSuchEntityException, PasswordPolicyViolationException, PolicyEvaluationException, PolicyNotAttachableException, ReportGenerationLimitExceededException, ServiceFailureException, ServiceNotSupportedException, UnmodifiableEntityException, UnrecognizedPublicKeyEncodingException