Class: Aws::QuickSight::Types::UpdateDashboardPublishedVersionRequest

Inherits:
Struct
  • Object
show all
Defined in:
gems/aws-sdk-quicksight/lib/aws-sdk-quicksight/types.rb

Overview

Note:

When making an API call, you may pass UpdateDashboardPublishedVersionRequest data as a hash:

{
  aws_account_id: "AwsAccountId", # required
  dashboard_id: "RestrictiveResourceId", # required
  version_number: 1, # required
}

Constant Summary collapse

SENSITIVE =
[]

Instance Attribute Summary collapse

Instance Attribute Details

#aws_account_idString

The ID of the AWS account that contains the dashboard that you're updating.

Returns:

  • (String)


9136
9137
9138
9139
9140
9141
9142
# File 'gems/aws-sdk-quicksight/lib/aws-sdk-quicksight/types.rb', line 9136

class UpdateDashboardPublishedVersionRequest < Struct.new(
  :aws_account_id,
  :dashboard_id,
  :version_number)
  SENSITIVE = []
  include Aws::Structure
end

#dashboard_idString

The ID for the dashboard.

Returns:

  • (String)


9136
9137
9138
9139
9140
9141
9142
# File 'gems/aws-sdk-quicksight/lib/aws-sdk-quicksight/types.rb', line 9136

class UpdateDashboardPublishedVersionRequest < Struct.new(
  :aws_account_id,
  :dashboard_id,
  :version_number)
  SENSITIVE = []
  include Aws::Structure
end

#version_numberInteger

The version number of the dashboard.

Returns:

  • (Integer)


9136
9137
9138
9139
9140
9141
9142
# File 'gems/aws-sdk-quicksight/lib/aws-sdk-quicksight/types.rb', line 9136

class UpdateDashboardPublishedVersionRequest < Struct.new(
  :aws_account_id,
  :dashboard_id,
  :version_number)
  SENSITIVE = []
  include Aws::Structure
end