AwsLambdaLayerVersionDetails - AWS Security Hub

AwsLambdaLayerVersionDetails

Details about a Lambda layer version.

Contents

CompatibleRuntimes

The layer's compatible runtimes. Maximum number of five items.

Valid values: nodejs10.x | nodejs12.x | java8 | java11 | python2.7 | python3.6 | python3.7 | python3.8 | dotnetcore1.0 | dotnetcore2.1 | go1.x | ruby2.5 | provided

Type: Array of strings

Pattern: .*\S.*

Required: No

CreatedDate

Indicates when the version was created.

Uses the date-time format specified in RFC 3339 section 5.6, Internet Date/Time Format. The value cannot contain spaces. For example, 2020-03-22T13:22:13.933Z.

Type: String

Pattern: .*\S.*

Required: No

Version

The version number.

Type: Long

Required: No

See Also

For more information about using this API in one of the language-specific AWS SDKs, see the following: