Aurora MySQL 資料庫引擎更新 2018-10-24 (2.03.1 版) (已棄用) - Amazon Aurora

本文為英文版的機器翻譯版本,如內容有任何歧義或不一致之處,概以英文版為準。

Aurora MySQL 資料庫引擎更新 2018-10-24 (2.03.1 版) (已棄用)

版本:2.03.1

Aurora MySQL 2.03.1 已全面推出。Aurora MySQL 2.x 版與 MySQL 5.7 版相容,Aurora MySQL 1.x 版則與 MySQL 5.6 版相容。

建立新的 Aurora MySQL 資料庫叢集時,您可以選擇要相容於 MySQL 5.7 或 MySQL 5.6。還原與 MySQL 5.6 相容的快照時,您可以選擇要相容於 MySQL 5.7 或 MySQL 5.6。

您可以將 Aurora MySQL 1.14.*、1.15.*、1.16.*、1.17.*、1.18.*、2.01.*、2.02.*、2.03 的快照還原為 Aurora MySQL 2.03.1。

我們不允許 Aurora MySQL 1.* 叢集就地升級至 Aurora MySQL 2.03.1,或從 Amazon S3 備份還原至 Aurora MySQL 2.03.1。我們預計在未來推出 Aurora MySQL 2.* 版時移除這些限制。

如果您有任何問題或疑慮,可以在社群論壇和 Support AWS 援中心取得 Sup AWS port。如需詳細資訊,請參閱《Amazon Aurora 使用者指南》中的維護 Amazon Aurora 資料庫叢集

注意

此版本目前不適用於 AWS GovCloud (美國西部) [us-gov-west-1] 和中國 (北京) [CN-北 -1] 地區。待該版本可供使用時,會再另行宣布。

改善項目

  • 修正以下問題:執行交易鎖死偵測時,Aurora Writer 可能重新啟動。

與 Aurora MySQL 第 1 版比較

下列 Amazon Aurora MySQL 功能在 Aurora MySQL 第 1 版 (與 MySQL 5.6 相容) 中有支援,但目前這些功能在 Aurora MySQL 第 2 版 (與 MySQL 5.7 相容) 中不支援。

MySQL 5.7 相容性

Aurora MySQL 2.03.1 有 MySQL 5.7 線路相容性,包括 JSON 支援、空間索引和產生欄位等功能。相較於 MySQL 5.7,Aurora MySQL 採用的空間索引原生實作主要利用 Z 階曲線,可為空間資料集提供超過 20 倍的寫入效能和超過 10 倍的讀取效能。

Aurora MySQL 2.03.1 目前不支援下列 MySQL 5.7 功能:

  • 全域交易識別符 (GTID)。Aurora MySQL 2.04 和以上版本支援 GTID。

  • 群組複寫外掛程式

  • 已增加的頁面大小

  • 啟動時載入 InnoDB 緩衝集區

  • InnoDB 全文剖析器外掛程式

  • 多來源複寫

  • 線上緩衝集區大小調整

  • 密碼驗證外掛程式

  • 查詢重寫外掛程式

  • 複寫篩選

  • CREATE TABLESPACE SQL 陳述式

  • X 通訊協定