Aurora MySQL 資料庫引擎更新 2019-12-23 (2.07.1 版) (已棄用) - Amazon Aurora

本文為英文版的機器翻譯版本,如內容有任何歧義或不一致之處,概以英文版為準。

Aurora MySQL 資料庫引擎更新 2019-12-23 (2.07.1 版) (已棄用)

Aurora MySQL 2.07.1 已全面推出。Aurora MySQL 2.x 版與 MySQL 5.7 版相容,Aurora MySQL 1.x 版則與 MySQL 5.6 版相容。

目前支援的 Aurora MySQL 版本包括 1.19.5、1.19.6、1.22.*、1.23.*、2.04.*、2.07.*、2.08.*、2.09.*、2.10.*、3.01.* 和 3.02.*。

您可以從目前支援的 Aurora MySQL 版本將快照還原至 Aurora MySQL 2.07.1。您還可以選擇將現有的 Aurora MySQL 2.* 資料庫叢集升級至 Aurora MySQL 2.07.1。您無法直接將現有的 Aurora MySQL 1.* 叢集升級至 2.07.1;不過,您可以將其快照還原至 Aurora MySQL 2.07.1。

若要使用較舊版本的 Aurora MySQL 建立叢集,請透過 AWS Management Console AWS CLI、或 RDS API 指定引擎版本。

注意

此版本目前不適用於以下 AWS 地區: AWS GovCloud (美國東部)[us-gov-east-1], AWS GovCloud (美國西部)[us-gov-west-1],中國(寧夏)[CN-西北 -1],亞太區域(香港)[ap-east-1] 和中東(巴林)[我-南 -1]。待該版本可供使用時,會再另行宣布。

如果您有任何問題或疑慮,可以在社群論壇和 Support AWS 援中心取得 Sup AWS port。如需詳細資訊,請參閱《Amazon Aurora 使用者指南》中的維護 Amazon Aurora 資料庫叢集

注意

如需如何升級 Aurora MySQL 資料庫叢集的詳細資訊,請參閱《Amazon Aurora 使用者指南》中的升級 Aurora MySQL 資料庫叢集的次要版本或修補程式層級

改善項目

高優先順序修正:

  • 已修正 Aurora 特定資料庫追蹤和記錄子系統中降低可用記憶體的緩慢記憶體流失。

整體穩定性修正:

  • 已修正在執行複雜查詢期間涉及內部使用中繼資料表的多重資料表聯結和彙總的當機。

與 Aurora MySQL 第 1 版比較

下列 Amazon Aurora MySQL 功能在 Aurora MySQL 第 1 版 (與 MySQL 5.6 相容) 中有支援,但目前這些功能在 Aurora MySQL 第 2 版 (與 MySQL 5.7 相容) 中不支援。

MySQL 5.7 相容性

此 Aurora MySQL 版本有 MySQL 5.7 線路相容性,包括 JSON 支援、空間索引和產生欄位等功能。相較於 MySQL 5.7,Aurora MySQL 採用的空間索引原生實作主要利用 Z 階曲線,可為空間資料集提供超過 20 倍的寫入效能和超過 10 倍的讀取效能。

此 Aurora MySQL 版本目前不支援下列 MySQL 5.7 功能:

  • 群組複寫外掛程式

  • 已增加的頁面大小

  • 啟動時載入 InnoDB 緩衝集區

  • InnoDB 全文剖析器外掛程式

  • 多來源複寫

  • 線上緩衝集區大小調整

  • 密碼驗證外掛程式

  • 查詢重寫外掛程式

  • 複寫篩選

  • CREATE TABLESPACE SQL 陳述式