Version : mises à jour de la plateforme Amazon Linux 2 pour Elastic Beanstalk le 3 mai 2021 - AWS Elastic Beanstalk

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Version : mises à jour de la plateforme Amazon Linux 2 pour Elastic Beanstalk le 3 mai 2021

Cette version fournit de nouvelles versions pour les plateformes AWS Elastic Beanstalk basées sur Amazon Linux 2. La version inclut des mises à jour de sécurité. Elle inclut également les mises à jour pour Docker, Go, Corretto, .NET, Core, PHP et Ruby, ainsi que certaines annonces d'obsolescence de plateforme.

Date de parution : 3 mai 2021

Modifications

Le tableau suivant répertorie les modifications incluses dans cette version.

Note

Sachez qu'au moment de la publication de ces notes de mise à jour, les nouvelles versions de plateforme peuvent ne pas encore être disponibles dans toutes les régions AWS prises en charge par Elastic Beanstalk. Plusieurs heures peuvent encore être nécessaires pour terminer la version.

Catégorie Description

Mises à jour de sécurité

Application de toutes les mises à jour de sécurité publiées dans le centre de sécurité Amazon Linux au plus tard le 21 avril 2021 dans toutes les plateformes Amazon Linux 2 existantes.

Les versions Corretto, Node.js, PHP et Ruby sont des versions de sécurité. Pour de plus amples informations, veuillez consulter Mises à jour spécifiques à une plateforme dans ce tableau.

Mises à jour multiplateformes

Application de ces mises à jour multiplateformes :

Composant Mettre à jour

AMI

Mise à jour de l'AMI de base vers la version 2.0.20210421.

Obsolescence de la plateforme

Nous annonçons aujourd'hui que plusieurs branches de plateforme basées sur Amazon Linux 2 seront mises hors service le 30 avril 2022 en raison de la fin de la prise en charge par les propriétaires de leurs composants d'exécution linguistique. Ces branches de plateforme sont désormais obsolètes. Si vous utilisez actuellement l'une de ces plateformes bientôt hors service, nous vous recommandons fortement de commencer à planifier votre migration de chacune d'entre elles vers une version actuelle intégralement prise en charge.

Les branches de plateforme suivantes sont désormais obsolètes :

  • Tomcat 7 (avec Corretto 11 et Corretto 8)

  • Node.js 10

  • PHP 7.2 et 7.3

  • Ruby 2.5

Les branches de plateforme obsolètes ne sont pas répertoriées sur la page Plateformes prises en charge du guide Plateformes AWS Elastic Beanstalk. Ils sont répertoriés sur une page séparée, Mise hors service de versions de plateforme.

Pour de plus amples informations sur l'obsolescence des plateformes, consultez Politique de prise en charge de la plateforme Elastic Beanstalk dans le Guide du développeur AWS Elastic Beanstalk.

Mises à jour spécifiques aux plateformes

Application de ces mises à jour spécifiques aux plateformes :

Plateforme Mettre à jour

Docker

Mise à jour de Docker vers la version 20.10.4.

Mise à jour de Docker Compose vers la version 1.29.1.

Go

Mise à jour de Go vers la version 1.16.3. Pour de plus amples informations, veuillez consulter go1.16 dans The Go Programming Language Release History.

Corretto

Mise à jour de Corretto 11 vers la version 11.0.11.9.1. Pour plus d'informations, consultez le journal des modifications Amazon Corretto 11 dans le référentiel Corretto 11 de GitHub.

Mise à jour de Corretto 8 vers la version 8.292.10.1. Pour plus d'informations, consultez le journal des modifications Amazon Corretto 8 dans le référentiel Corretto 8 de GitHub.

Les deux mises à jour Corretto sont des versions de sécurité.

.NET Core

Mise à jour de .NET Core vers les versions 5.0.4, 3.1.14 et 2.1.27.

Node.js

Mise à jour de Node.js 14 pour ajouter la prise en charge de la version Node 14.16.1.

Mise à jour de Node.js 12 pour ajouter la prise en charge des versions Node 12.22.1 et 12.22.0.

Les nouvelles versions de Node.js sont des versions de sécurité.

PHP

Mise à jour de Composer vers la version 2.0.13 pour PHP 8.0 et la version 1.10.22 pour PHP 7.4. Pour plus d'informations, consultez la section Releases dans le référentiel Composer de GitHub.

Ces mises à jour sont des versions de sécurité.

Ruby

Mise à jour de Ruby 2.7 et 2.6 vers les versions 2.7.3 et 2.6.7, respectivement.

Mise à jour de RubyGems vers la version 3.2.15.

Les mises à jour Ruby 2.7 et 2.6 sont des versions de sécurité.

Nouvelles versions de plateforme

Note

Les tableaux suivants répertorient toutes les branches de plateforme prises en charge pour chaque plateforme. Seules les branches de la plateforme Amazon Linux 2 sont mises à jour.

Docker

Version de plateforme et Nom de la pile de solutions

AMI

Docker

Docker Compose

Serveur proxy

Docker AL2 version 3.3.0

64bit Amazon Linux 2 v3.3.0 running Docker

2.0.20210421

20.10.4

1.29.1

nginx 1.18.0

Single Container Docker version 2.16.7

64bit Amazon Linux 2018.03 v2.16.7 running Docker 19.03.13-ce

2018.03.0

19.03.13-ce

nginx 1.18.0

Go

Version de plateforme et Nom de la pile de solutions

AMI

Langage

AWS X‑Ray

Serveur proxy

Go 1 AL2 version 3.2.2

64bit Amazon Linux 2 v3.2.2 running Go 1

2.0.20210421

Go 1.16.3

3.2.0

nginx 1.18.0

Go 1 version 2.18.2

64bit Amazon Linux 2018.03 v2.18.2 running Go 1.16.3

2018.03.0

Go 1.16.3

3.1.0

nginx 1.18.0

Java SE

Version de plateforme et Nom de la pile de solutions

AMI

Langage

Outils

AWS X‑Ray

Serveur proxy

Corretto 11 version 3.1.8

64bit Amazon Linux 2 v3.1.8 running Corretto 11

2.0.20210421

Corretto 11.0.11.9.1

Ant 1.10.7, Gradle 5.6.2, Maven 3.6.2

3.2.0

nginx 1.18.0

Corretto 8 version 3.1.8

64bit Amazon Linux 2 v3.1.8 running Corretto 8

2.0.20210421

Corretto 8.292.10.1

Ant 1.10.7, Gradle 5.6.2, Maven 3.6.2

3.2.0

nginx 1.18.0

Java 8 version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Java 8

2018.03.0

Java 1.8.0_282

Ant 1.9.6, Gradle 2.7, Maven 3.3.3

3.1.0

nginx 1.18.0

Java 7 version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Java 7

2018.03.0

Java 1.7.0_261

Ant 1.9.6, Gradle 2.7, Maven 3.3.3

3.1.0

nginx 1.18.0

Tomcat

Version de plateforme et Nom de la pile de solutions

AMI

Langage

AWS X‑Ray

Serveur d'application

Serveur proxy

Corretto 11 with Tomcat 8.5 AL2 version 4.1.8

64bit Amazon Linux 2 v4.1.8 running Tomcat 8.5 Corretto 11

2.0.20210421

Corretto 11.0.11.9.1

3.2.0

Tomcat 8.5.63

nginx 1.18.0 (par défaut), Apache 2.4.46

Corretto 8 with Tomcat 8.5 AL2 version 4.1.8

64bit Amazon Linux 2 v4.1.8 running Tomcat 8.5 Corretto 8

2.0.20210421

Corretto 8.292.10.1

3.2.0

Tomcat 8.5.63

nginx 1.18.0 (par défaut), Apache 2.4.46

Java 8 with Tomcat 8.5 version 3.4.6

64bit Amazon Linux 2018.03 v3.4.6 running Tomcat 8.5 Java 8

2018.03.0

Java 1.8.0_282

3.1.0

Tomcat 8.5.63

Apache 2.4.46 (par défaut), Nginx 1.18.0

.NET Core sous Linux

Version de plateforme et Nom de la pile de solutions

Cadre

Serveur proxy

AMI

AWS X‑Ray

.NET Core on AL2 version 2.1.5

64bit Amazon Linux 2 v2.1.5 running .NET Core

.NET 5.0.5, prend en charge 5.0.5, 3.1.14, 2.1.27

nginx 1.18.0

2.0.20210421

3.2.0

Node.js

Version de plateforme et Nom de la pile de solutions

AMI

Versions Node.js (versions npm)

Serveur proxy

Git

AWS X‑Ray

Node.js 14 AL2 version 5.3.2

64bit Amazon Linux 2 v5.3.2 running Node.js 14

2.0.20210421

14.16.1 (6.14.12), 14.16.0 (6.14.11), 14.15.5 (6.14.11), 14.15.4 (6.14.10), 14.15.3 (6.14.9), 14.15.2 (6.14.9), 14.15.1 (6.14.8), 14.15.0 (6.14.8), 14.14.0 (6.14.8), 14.13.1 (6.14.8), 14.13.0 (6.14.8), 14.12.0 (6.14.8), 14.11.0 (6.14.8), 14.10.1 (6.14.8), 14.10.0 (6.14.8), 14.9.0 (6.14.8), 14.8.0 (6.14.7), 14.7.0 (6.14.7), 14.6.0 (6.14.6), 14.5.0 (6.14.5), 14.4.0 (6.14.5), 14.3.0 (6.14.5), 14.2.0 (6.14.4), 14.1.0 (6.14.4), 14.0.0 (6.14.4)

Version par défaut : 14.16.1

nginx 1.18.0 (par défaut), Apache 2.4.46

2.23.4

3.2.0

Node.js 12 AL2 version 5.3.2

64bit Amazon Linux 2 v5.3.2 running Node.js 12

2.0.20210421

12.22.1 (6.14.12), 12.22.0 (6.14.11), 12.21.0 (6.14.11), 12.20.2 (6.14.11), 12.20.1 (6.14.10), 12.20.0 (6.14.8), 12.19.1 (6.14.8), 12.19.0 (6.14.8), 12.18.4 (6.14.6), 12.18.3 (6.14.6), 12.18.2 (6.14.5), 12.18.1 (6.14.5), 12.18.0 (6.14.4), 12.17.0 (6.14.4), 12.16.3 (6.14.4), 12.16.2 (6.14.4), 12.16.1 (6.13.4), 12.16.0 (6.13.4), 12.15.0 (6.13.4), 12.14.1 (6.13.4), 12.14.0 (6.13.4), 12.13.1 (6.12.1), 12.13.0 (6.12.0), 12.12.0 (6.11.3), 12.11.1 (6.11.3), 12.11.0 (6.11.3), 12.10.0 (6.10.3), 12.9.1 (6.10.2), 12.9.0 (6.10.2), 12.8.1 (6.10.2), 12.8.0 (6.10.2), 12.7.0 (6.10.0), 12.6.0 (6.9.0), 12.5.0 (6.9.0), 12.4.0 (6.9.0), 12.3.1 (6.9.0), 12.3.0 (6.9.0), 12.2.0 (6.9.0), 12.1.0 (6.9.0), 12.0.0 (6.9.0)

Version par défaut : 12.22.1

nginx 1.18.0 (par défaut), Apache 2.4.46

2.23.4

3.2.0

Node.js version 4.17.5

64bit Amazon Linux 2018.03 v4.17.5 running Node.js

2018.03.0

12.22.1 (6.14.12), 12.22.0 (6.14.11), 12.21.0 (6.14.11), 12.20.2 (6.14.11), 12.20.1 (6.14.10), 12.20.0 (6.14.8), 12.19.1 (6.14.8), 12.19.0 (6.14.8), 12.18.4 (6.14.6),12.18.3 (6.14.6), 12.18.2 (6.14.5), 12.18.1 (6.14.5), 12.18.0 (6.14.4), 12.16.4 (6.14.4), 12.16.2 (6.14.4), 12.16.1 (6.13.4), 12.15.0 (6.13.4), 12.14.1 (6.13.4), 12.14.0 (6.13.4), 10.24.1 (6.14.12), 10.24.0 (6.14.11), 10.23.3 (6.14.11), 10.23.2 (6.14.10), 10.23.1 (6.14.10), 10.23.0 (6.14.8), 10.22.1 (6.14.6), 10.22.0 (6.14.6), 10.21.0 (6.14.4), 10.20.1 (6.14.4), 10.20.0(6.14.4), 10.19.0 (6.13.4), 10.18.1 (6.13.4), 10.18.0 (6.13.4), 10.17.0 (6.11.3), 10.16.3 (6.9.0), 10.16.2 (6.9.0), 10.16.1 (6.9.0), 10.16.0 (6.9.0), 10.15.3 (6.4.1), 10.15.1 (6.4.1), 10.15.0 (6.4.1), 10.14.1 (6.4.1)

Version par défaut : 12.22.1

nginx 1.18.0, Apache 2.4.43

2.18.5

3.1.0

PHP

Version de plateforme et Nom de la pile de solutions

AMI

Langage

Composer

Serveur proxy

PHP 8.0 AL2 version 3.2.1

64bit Amazon Linux 2 v3.2.1 running PHP 8.0

2.0.20210421

PHP 8.0.2

2.0.13

nginx 1.18.0 (par défaut), Apache 2.4.46

PHP 7.4 AL2 version 3.2.1

64bit Amazon Linux 2 v3.2.1 running PHP 7.4

2.0.20210421

PHP 7.4.15

1.10.22

nginx 1.18.0 (par défaut), Apache 2.4.46

Python

Version de plateforme et Nom de la pile de solutions

AMI

Langage

Gestionnaire de package

Outil de création de package

meld3

AWS X‑Ray

Serveur proxy

Python 3.8 AL2 version 3.2.2

64bit Amazon Linux 2 v3.2.2 running Python 3.8

2.0.20210421

Python 3.8.5

pipenv 2020.8.13

3.2.0

nginx 1.18.0 (par défaut), Apache 2.4.46

Python 3.7 AL2 version 3.2.2

64bit Amazon Linux 2 v3.2.2 running Python 3.7

2.0.20210421

Python 3.7.9

pipenv 2020.8.13

3.2.0

nginx 1.18.0 (par défaut), Apache 2.4.46

Python 3.6 version 2.10.0

64bit Amazon Linux 2018.03 v2.10.0 running Python 3.6

2018.03.0

Python 3.6.12

pip 9.0.3

setuptools 56.0.0

meld3 1.0.2

3.1.0

Apache 2.4.46 avec mod_wsgi 3.5

Ruby

Version de plateforme et Nom de la pile de solutions

AMI

Langage

Gestionnaire de package

Serveur d'application

AWS X‑Ray

Serveur proxy

Ruby 2.7 AL2 version 3.2.5

64bit Amazon Linux 2 v3.2.5 running Ruby 2.7

2.0.20210421

Ruby 2.7.3-p183

RubyGems 3.2.15

Puma 5.2.2

3.2.0

nginx 1.18.0

Ruby 2.6 AL2 version 3.2.5

64bit Amazon Linux 2 v3.2.5 running Ruby 2.6

2.0.20210421

Ruby 2.6.7-p197

RubyGems 3.2.15

Puma 5.2.2

3.2.0

nginx 1.18.0

Ruby 2.6 with Puma version 2.12.6

64bit Amazon Linux 2018.03 v2.12.6 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.7-p197

RubyGems 3.2.15

Puma 2.16.0

3.1.0

nginx 1.18.0

Ruby 2.6 with Passenger version 2.12.6

64bit Amazon Linux 2018.03 v2.12.6 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.7-p197

RubyGems 3.2.15

Passenger 4.0.60

3.1.0

nginx 1.18.0