Solución de problemas de lanzamiento de instancias - Amazon Elastic Compute Cloud

Solución de problemas de lanzamiento de instancias

Los siguientes problemas impiden lanzar una instancia.

Límite de la instancia excedido

Descripción

Se obtiene el error InstanceLimitExceeded cuando se intenta lanzar una nueva instancia o reiniciar una instancia parada.

Causa

Si recibe un error InstanceLimitExceeded cuando intenta lanzar una nueva instancia o reiniciar una instancia detenida, ha alcanzado el límite en el número de instancias que puede lanzar en una región. Cuando cree la cuenta de AWS, establecemos los límites predeterminados en el número de instancias que puede ejecutar por región.

Solución

Puede solicitar un aumento de límite de instancias por región. Para obtener más información, consulte Cuotas de servicio de Amazon EC2.

Capacidad de la instancia insuficiente

Descripción

Se obtiene el error InsufficientInstanceCapacity cuando se intenta lanzar una nueva instancia o reiniciar una instancia parada.

Causa

Si recibe un error InsufficientInstanceCapacity cuando intenta lanzar la instancia o reiniciar una instancia detenida, AWS no tiene actualmente capacidad bajo demanda disponible para dar servicio a la solicitud.

Solución

Para resolver este problema, pruebe lo siguiente:

  • Espere unos minutos y después envíe la solicitud de nuevo; la capacidad puede cambiar frecuentemente.

  • Envíe una nueva solicitud con una cantidad reducida de instancias. Por ejemplo, si hace una única solicitud para lanzar 15 instancias, intente hacer 3 solicitudes para 5 instancias, o 15 solicitudes para 1 instancia en su lugar.

  • Si está lanzando una instancia, envíe una nueva solicitud sin especificar ninguna zona de disponibilidad.

  • Si está lanzando una instancia, envíe una nueva solicitud usando un tipo de instancia distinto (que puede cambiar de tamaño en una fase posterior). Para obtener más información, consulte Cambio del tipo de instancia.

  • Si está lanzando instancias en un grupo de ubicación en clúster, es posible que reciba un error de capacidad insuficiente. Para obtener más información, consulte Reglas y limitaciones de los grupos de ubicación.

  • Pruebe a crear una Reserva de capacidad bajo demanda, que le permite reservar capacidad de Amazon EC2 para cualquier duración. Para obtener más información, consulte Reservas de capacidad bajo demanda.

  • Pruebe a comprar instancias reservadas, que son una reserva de capacidad a largo plazo. Para obtener más información, consulte Instancias reservadas de Amazon EC2.

La instancia termina inmediatamente

Descripción

La instancia pasa del estado pending al estado terminated inmediatamente después de reiniciarla.

Causa

A continuación se ofrecen unas cuantas razones sobre por qué una instancia puede terminar de inmediato:

  • Ha alcanzado el límite del volumen EBS.

  • Una instantánea de EBS está dañada.

  • El volumen de EBS raíz está cifrado y no tiene permisos para acceder a la clave de KMS para descifrado.

  • A la AMI con respaldo en el almacén de instancias que utilizaba para lanzar la instancia le falta una parte obligatoria (un archivo image.part.xx).

Solución

Puede utilizar la consola de Amazon EC2 o la AWS Command Line Interface para obtener el motivo de la terminación.

Para obtener el motivo de la terminación utilizando la consola de Amazon EC2

  1. Abra la consola de Amazon EC2 en https://console.aws.amazon.com/ec2/.

  2. En el panel de navegación, elija Instances (Instancias) y seleccione la instancia.

  3. En la pestaña Description (Descripción), anote el motivo junto a la etiqueta State transition reason (Motivo de transición de estado).

Para obtener el motivo de la terminación utilizando la consola de AWS Command Line Interface

  1. Use el comando describe-instances y especifique el ID de instancia.

    aws ec2 describe-instances --instance-id instance_id
  2. Revise la respuesta JSON devuelta por el comando y anote los valores en el elemento de respuesta StateReason.

    En el siguiente bloque de código se muestra un ejemplo de un elemento de respuesta StateReason.

    "StateReason": { "Message": "Client.VolumeLimitExceeded: Volume limit exceeded", "Code": "Server.InternalError" },

Para solucionar el problema

Realice una de las siguientes acciones en función del motivo de terminación que anotó:

  • Si el motivo es Client.VolumeLimitExceeded: Volume limit exceeded, ha alcanzado el límite de volumen de EBS. Para obtener más información, consulte Límites de volumen de instancias. Para solicitar un aumento del límite del volumen de Amazon EBS, rellene el formulario Create Case del Centro de AWS Support. Para obtener más información, consulte Cuotas de servicio de Amazon EC2.

  • Si el motivo es Client.InternalError: Client error on launch, que normalmente indica que el volumen raíz está cifrado y no tiene permisos para acceder a la clave de KMS para descifrado. Para obtener permisos para acceder a la clave de KMS requerida, añada los permisos de KMS adecuados a su usuario de IAM. Para obtener más información, consulte Uso de políticas de claves en AWS KMS en la AWS Key Management Service Developer Guide.