Créer ou ouvrir un bloc-notes Amazon SageMaker Studio - Amazon SageMaker

Créer ou ouvrir un bloc-notes Amazon SageMaker Studio

Lorsque vous créez un bloc-notes dans Amazon SageMaker Studio ou ouvrez un bloc-notes non partagé dans Studio pour la première fois, vous devez sélectionner une image et un noyau SageMaker pour le bloc-notes. SageMaker lance le bloc-notes sur une instance par défaut dont le type est basé sur l'image SageMaker choisie. Pour les images basées sur le processeur, le type d'instance par défaut est ml.t3.medium (disponible dans le cadre de l'offre gratuite AWS). Pour les images basées sur un processeur graphique, le type d'instance par défaut est ml.g4dn.xlarge.

Si vous créez ou ouvrez des blocs-notes supplémentaires qui utilisent le même type d'instance, qu'ils utilisent ou non le même noyau, les blocs-notes s'exécutent sur la même instance de ce type d'instance.

Après le lancement d'un bloc-notes, vous pouvez modifier son type d'instance, son image SageMaker et son noyau depuis le bloc-notes. Pour plus d'informations, consultez Modifier un type d'instance et Modifier un noyau.

Vous pouvez avoir une seule instance de chaque type d'instance. Chaque instance peut comporter plusieurs images SageMaker en cours d'exécution. Chaque image SageMaker peut exécuter plusieurs noyaux ou instances de terminal.

La facturation est définie par instance et démarre au lancement de la première instance d'un type d'instance donné. Si vous souhaitez créer ou ouvrir un bloc-notes sans risquer de frais, ouvrez le bloc-notes dans le menu Fichier, choisissez Aucun noyau dans la boîte de dialogue Sélectionner un noyau. Vous pouvez lire et modifier un bloc-notes sans noyau en cours d'exécution, mais vous ne pouvez pas exécuter de cellules de code.

La facturation s'arrête lorsque l'image SageMaker de l'instance est arrêtée. Pour plus d'informations, consultez Comptage d'utilisation.

Pour plus d'informations sur l'arrêt du bloc-notes, veuillez consulter Arrêter les ressources.

Ouvrir un bloc-notes Studio

SageMaker Studio ne peut ouvrir que les blocs-notes répertoriés dans le navigateur de fichiers Studio. Pour obtenir des instructions sur le téléchargement d'un bloc-notes au navigateur de fichiers, veuillez consulter Télécharger des fichiers dans SageMaker Studio ou Cloner un référentiel Git dans SageMaker Studio.

Pour ouvrir un bloc-notes

  1. Dans la barre latérale gauche, choisissez l'icône File Browser (Explorateur de fichiers) ( ) pour afficher l'Explorateur de fichiers.

  2. Accédez à un fichier de bloc-notes et cliquez deux fois dessus pour l'ouvrir dans un nouvel onglet.

Créer un bloc-notes à partir du menu File (Fichier)

Pour créer un bloc-notes à partir du menu File (Fichier)

  1. Dans le menu de Studio, choisissez File (Fichier), New (Nouveau), puis Notebook (Bloc-notes).

  2. Dans la boîte de dialogue Select Kernel (Sélectionner un noyau), pour utiliser le noyau par défaut, Python 3 (Data Science), choisissez Select (Sélectionner). Sinon, utilisez le menu déroulant pour sélectionner un noyau différent.

Pour obtenir la liste des noyaux disponibles, veuillez consulter Noyaux Amazon SageMaker disponibles.

Créer un bloc-notes à partir du lanceur

Pour créer un bloc-notes à partir du lanceur

  1. Pour ouvrir le lanceur, utilisez le raccourci clavier Ctrl + Shift + L.

    Sinon, dans le navigateur de fichiers, choisissez le signe plus (+) à gauche du menu.

  2. Dans le lanceur, conservez l'image SageMaker par défaut, Data Science ou utilisez le menu déroulant pour sélectionner une autre image.

  3. Sous Notebook (Bloc-notes), choisissez Python3.

Pour obtenir la liste des images disponibles, veuillez consulter Images Amazon SageMaker disponibles.

Une fois que vous avez choisi le noyau ou l'image, votre bloc-notes se lance et s'ouvre dans un nouvel onglet Studio. Pour afficher la session de noyau du bloc-notes, dans la barre latérale de gauche, choisissez l'icône Running Terminals, Kernels, and Images (Terminaux, noyaux et images en cours d'exécution) ( ). Vous pouvez arrêter la session de noyau du bloc-notes à partir de cette vue.