AWSSDK for Ruby 发人员指南 - 适用于 Ruby 的 AWS 开发工具包

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

AWSSDK for Ruby 发人员指南

欢迎使用AWS适 SDK for Ruby。

这些区域有:AWS适 SDK for Ruby 提供了适用于几乎所有AWS服务,包括 Amazon Simple Storage Service、Amazon Elastic Compute Cloud 和 Amazon DynamoDB。要获取由AWS适 SDK for Ruby,请参阅支持的服务的 部分AWS适 SDK for Ruby 自述文件。此部分还列出了AWS适 SDK for Ruby 支持,因为版本 3 将整个开发工具包 Gem 模块化为多个特定于服务的 Gem。

使用AWS适 SDK for RubyAWS Cloud9

AWS Cloud9是一个基于 Web 的集成开发环境 (IDE),其中包含一系列工具,可用于在云中编码、构建、运行、测试、调试和发布软件。

请参阅使用AWS Cloud9使用AWSSDK for Ruby,了解有关使用AWS Cloud9使用AWS适 SDK for Ruby。

关于本指南

这些区域有:AWS适用 SDK for Ruby 的开发人员指南提供有关如何安装、设置和使用AWSSDK for Ruby 来创建使用AWS服务。

本指南包含以下部分:

入门AWSSDK for Ruby

介绍如何安装、配置和使用AWS适 SDK for Ruby。

配置AWSSDK for Ruby

逐步了解如何配置AWS适 SDK for Ruby。

使用AWSSDK for Ruby

提供有关使用开发应用程序的一般信息。AWS适 SDK for Ruby。

AWS SDK for Ruby 代码示例

提供编程的代码示例AWS服务AWS适 SDK for Ruby。您可以浏览AWS适 SDK for RubyAWS代码示例目录

AWS 适 SDK for Ruby 提示和技巧

提供有关使用AWS适 SDK for RubyAWS服务。

文档历史记录

介绍本文档的历史记录。

其他文档和资源

有关更多资源AWS适 SDK for Ruby,请参阅以下内容:

部署到AWS云

您可以使用AWS服务,如AWS Elastic Beanstalk、AWS OpsWorks和 CodeDeploy 将应用程序部署到AWS云。要使用 Elastic Beanstalk 部署 Ruby 应用程序,请参阅在 Ruby 中使用 EB CLI 和 Git 部署 Elastic Beanstalk 应用程序中的AWS Elastic Beanstalk开发人员指南 的第一个版本。要使用部署 Ruby on Rails 应用程序AWS OpsWorks,请参阅将 Ruby on Rails 应用程序部署到AWSOpsWorks。有关的概述AWS部署服务,请参阅部署选项概述AWS

开发工具包主要版本的维护和支持

有关维护和支持开发工具包主要版本及其基础依赖关系的信息,请参阅AWSSDK 和工具共享配置和凭据参考指南