Installation, Aktualisierung und Deinstallation der AWS CLI - AWS Command Line Interface

Diese Dokumentation bezieht sich ausschließlich auf Version 1 der AWS CLI. Eine Dokumentation zu Version 2 der AWS CLI finden Sie im Benutzerhandbuch für Version 2.

Installation, Aktualisierung und Deinstallation der AWS CLI

In diesem Thema finden Sie Links zum Installieren, Aktualisieren und Deinstallieren der Originalversion der AWS Command Line Interface (AWS CLI). Die AWS CLI Version 1 wird derzeit unterstützt, jedoch wurden neue Funktionen, die der AWS CLI Version 2 hinzugefügt wurden, möglicherweise nicht der AWS CLI Version 1 hinzugefügt. Um diese Funktionen zu verwenden, müssen Sie die AWS CLI Version 2 installieren. Weitere Informationen zum Installieren von Version 2 finden Sie unter Installieren der AWS CLI Version 2.

Anweisungen zum Installieren, Aktualisieren und Deinstallieren der AWS CLI:

Anforderungen an Python-Versionen

Die AWS CLI Version 1 wird mit dem SDK für Python erstellt und erfordert daher, dass Sie eine kompatible Version von Python installieren.

Support für Python-Versionen-Matrix
AWS CLI-Version Unterstützte Python-Versionen
1.20.0 bis aktuell Python 3.6+
1.19.0 bis 1.19.x Python 2.7+ oder Python 3.6+
1.17 - 1.18.x Python 2.7+, Python 3.4+
1.0 - 1.16.x Python 2.6 und älter, Python 3.3 und älter